aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-21 20:18:20 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-04-21 22:48:27 +0300
commite05ae2415fc7bcede3382995b5689932237be373 (patch)
treef77cf8c3aafb229c6159bee25e6ca7f3e76a35a1
parentlxqt-base/lxqt-notificationd: add 2.0.0 (diff)
downloadqt-e05ae2415fc7bcede3382995b5689932237be373.tar.gz
qt-e05ae2415fc7bcede3382995b5689932237be373.tar.bz2
qt-e05ae2415fc7bcede3382995b5689932237be373.zip
lxqt-base/lxqt-openssh-askpass: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--lxqt-base/lxqt-openssh-askpass/Manifest1
-rw-r--r--lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-2.0.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-openssh-askpass/Manifest b/lxqt-base/lxqt-openssh-askpass/Manifest
new file mode 100644
index 00000000..50661685
--- /dev/null
+++ b/lxqt-base/lxqt-openssh-askpass/Manifest
@@ -0,0 +1 @@
+DIST lxqt-openssh-askpass-2.0.0.tar.xz 17812 BLAKE2B cc3dd5694d436ae889dc42ea128896caf80745a1fbd6d017d144b3a016f72f68482dad660b7e79c9e5c3f937bcc29da30926bfb4cd92ccee426abfc945e14f29 SHA512 571182fb9a1610bd5e61ad5ffe68083c66391e73a10c8ce58972ec7bbad7f0244f3b93fdd25cf24196add290dce03393eb560bd0e0dee18da81b02c7faec6b4c
diff --git a/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-2.0.0.ebuild b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-2.0.0.ebuild
new file mode 100644
index 00000000..4382d497
--- /dev/null
+++ b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-2.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt OpenSSH user password prompt tool"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ >=dev-qt/qtbase-6.6:6[widgets]
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+
+ newenvd - 99${PN} <<- _EOF_
+ SSH_ASKPASS='${EPREFIX}/usr/bin/lxqt-openssh-askpass'
+ _EOF_
+}