aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 17:42:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 17:42:52 +0100
commitd2fdb2bec516c1e1326b9320f53815fce0d11b4c (patch)
treedd2c0c808ada8f7d55a571ce1af02fb00ae4ebf3 /dev-libs
parentapp-crypt/qca: Switch to cmake.eclass and kde.org.eclass (diff)
downloadqt-d2fdb2bec516c1e1326b9320f53815fce0d11b4c.tar.gz
qt-d2fdb2bec516c1e1326b9320f53815fce0d11b4c.tar.bz2
qt-d2fdb2bec516c1e1326b9320f53815fce0d11b4c.zip
dev-libs/libsystemd-qt: Switch to cmake.eclass, EAPI-7 bump
Add missing RESTRICT="!test? ( test )" Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libsystemd-qt/libsystemd-qt-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/libsystemd-qt/libsystemd-qt-9999.ebuild b/dev-libs/libsystemd-qt/libsystemd-qt-9999.ebuild
index e3e97a63..94cef0ea 100644
--- a/dev-libs/libsystemd-qt/libsystemd-qt-9999.ebuild
+++ b/dev-libs/libsystemd-qt/libsystemd-qt-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/scarpin0/${PN}.git"
@@ -22,6 +22,8 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="debug test"
+RESTRICT="!test? ( test )"
+
RDEPEND="
${SYSTEMD_VERSION}
dev-qt/qtcore:5
@@ -37,5 +39,5 @@ src_configure() {
-DBUILD_QTSYSTEMD_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}