aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-03-09 21:08:24 +0200
committerJimi Huotari <chiitoo@gentoo.org>2022-03-09 21:08:24 +0200
commit1456aeb4fe4d4475e581df1d604234da87ce07be (patch)
tree80aeb695dd1daa3cd3314848ccbd88359820cf3a /x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
parentapp-arch/lxqt-archiver: sync with the latest release ebuild (diff)
downloadqt-1456aeb4fe4d4475e581df1d604234da87ce07be.tar.gz
qt-1456aeb4fe4d4475e581df1d604234da87ce07be.tar.bz2
qt-1456aeb4fe4d4475e581df1d604234da87ce07be.zip
x11-themes/lxqt-themes: sync with the latest release ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'x11-themes/lxqt-themes/lxqt-themes-9999.ebuild')
-rw-r--r--x11-themes/lxqt-themes/lxqt-themes-9999.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild b/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
index 22f37c6f..80f6d606 100644
--- a/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
+++ b/x11-themes/lxqt-themes/lxqt-themes-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake
+inherit cmake xdg-utils
DESCRIPTION="LXQt Themes"
-HOMEPAGE="https://lxqt.github.io/"
+HOMEPAGE="https://lxqt-project.org/"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
@@ -19,4 +19,12 @@ fi
LICENSE="LGPL-2.1+"
SLOT="0"
-BDEPEND=">=dev-util/lxqt-build-tools-0.9.0"
+BDEPEND=">=dev-util/lxqt-build-tools-0.10.0"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}