aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-05-04 08:53:23 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-04 08:53:23 +0100
commit2b304d8ee40c38023411a3ea184c29ad5a1f8070 (patch)
tree0018fa870e7219514309aa7906fcf2bb742590bd /Makefile.am
parentconfigure.ac: release 2.23 (diff)
downloadsandbox-2b304d8ee40c38023411a3ea184c29ad5a1f8070.tar.gz
sandbox-2b304d8ee40c38023411a3ea184c29ad5a1f8070.tar.bz2
sandbox-2b304d8ee40c38023411a3ea184c29ad5a1f8070.zip
Makefile.am: don't mangle final binary with sed
In bug #774861 pash found out that /bin/sh -> busybox produces invalid `sandbox` binary. It happens because `busybox sed` does not implement hex escape insertions, like: $ printf "a" | gnu-sed 's/a/\x00/' | hexdump -C 00000000 00 |.| $ printf "a" | busybox sed 's/a/\x00/' | hexdump -C 00000000 78 30 30 |x00| The change exposes `__SANDBOX_TESTING` variable to external users. Reported-by: pash Bug: https://bugs.gentoo.org/774861 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 0 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 5541f67..b0ea65f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,12 +47,3 @@ dist-hook:
touch "$(distdir)/ChangeLog" ; \
fi ; \
fi
-
-install-exec-hook:
- set -e ; \
- for f in $(bindir)/sandbox $(libdir)/libsandbox.so ; do \
- sed -i.tmp \
- 's:__SANDBOX_TESTING:\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00:' \
- $(DESTDIR)$$f ; \
- rm -f $(DESTDIR)$$f.tmp ; \
- done