aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-11 08:23:51 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-11 08:23:51 +0000
commitd3953761f66476d7a0e6a38ede57661b4d190589 (patch)
treefe376d0a19f6c0633221f70c7a4fc0db7b025c26 /configure.ac
parentmove build flags to configure rather than Makefile (diff)
downloadsandbox-d3953761f66476d7a0e6a38ede57661b4d190589.tar.gz
sandbox-d3953761f66476d7a0e6a38ede57661b4d190589.tar.bz2
sandbox-d3953761f66476d7a0e6a38ede57661b4d190589.zip
tests: initial test framework
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5235aae..c742274 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,7 @@ AC_PROG_INSTALL
AC_PROG_MAKE_SET
AC_PROG_AWK
AC_CHECK_PROGS([READELF], [readelf eu-readelf], [false])
+AM_MISSING_PROG([AUTOM4TE], [autom4te])
AC_ENABLE_SHARED
AC_DISABLE_STATIC
@@ -46,6 +47,7 @@ AC_CHECK_HEADERS_ONCE([ \
stdlib.h \
string.h \
strings.h \
+ syscall.h \
unistd.h \
utime.h \
sys/file.h \
@@ -237,6 +239,8 @@ if test "$GCC" = yes; then
CFLAGS="$CFLAGS -Wall"
fi
+AC_CONFIG_TESTDIR([tests])
+
AC_OUTPUT([
Makefile
scripts/Makefile
@@ -245,4 +249,7 @@ AC_OUTPUT([
libsbutil/Makefile
libsandbox/Makefile
src/Makefile
+ tests/atlocal
+ tests/Makefile
+ tests/package.m4
])