aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-19 12:19:11 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-10-22 10:32:15 +0200
commite3f613ae6e8d20ac6dadd33f363960cc803343b3 (patch)
treef398702f309fe5f240c4b0c57cb4d6290981a557 /dev-python/hist/hist-2.8.0.ebuild
parentdev-python/vector: add 1.5.2 (diff)
downloadsci-e3f613ae6e8d20ac6dadd33f363960cc803343b3.tar.gz
sci-e3f613ae6e8d20ac6dadd33f363960cc803343b3.tar.bz2
sci-e3f613ae6e8d20ac6dadd33f363960cc803343b3.zip
dev-python/hist: add 2.8.0
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
Diffstat (limited to 'dev-python/hist/hist-2.8.0.ebuild')
-rw-r--r--dev-python/hist/hist-2.8.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/hist/hist-2.8.0.ebuild b/dev-python/hist/hist-2.8.0.ebuild
new file mode 100644
index 000000000..04160951e
--- /dev/null
+++ b/dev-python/hist/hist-2.8.0.ebuild
@@ -0,0 +1,26 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+DISTUTILS_USE_PEP517=hatchling
+SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1 pypi
+
+DESCRIPTION="Histogramming for analysis powered by boost-histogram "
+HOMEPAGE="https://github.com/scikit-hep/hist"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/boost-histogram-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/histoprint-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.14.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+RESTRICT="test"
+# needs mplhep and dask_histogram ...
+#distutils_enable_tests pytest