aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorleycec <leycec@gmail.com>2021-08-07 01:22:56 -0400
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-07 09:31:21 +0200
commit4ecc14e3f25eea035d0342c9a7ef149f78db656e (patch)
tree6f2be94853c4bd6faeb48b5c5f42e791f09bb805 /dev-python/typish
parentdev-python/cadquery-ocp: add PYTHON_SINGLE_USEDEP to lief dep (diff)
downloadsci-4ecc14e3f25eea035d0342c9a7ef149f78db656e.tar.gz
sci-4ecc14e3f25eea035d0342c9a7ef149f78db656e.tar.bz2
sci-4ecc14e3f25eea035d0342c9a7ef149f78db656e.zip
dev-python/typish: add
add typish, a mandatory dependency of nptyping, itself a mandatory dependency of CadQuery Signed-off-by: Cecil Curry <leycec@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/typish')
-rw-r--r--dev-python/typish/Manifest1
-rw-r--r--dev-python/typish/metadata.xml13
-rw-r--r--dev-python/typish/typish-1.9.3.ebuild21
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/typish/Manifest b/dev-python/typish/Manifest
new file mode 100644
index 000000000..672b11f96
--- /dev/null
+++ b/dev-python/typish/Manifest
@@ -0,0 +1 @@
+DIST typish-1.9.3.tar.gz 22997 BLAKE2B f399f5d9b3ae8f85f3b719de77d675b142ac45b6535f66d9d0d999411bc5bfc9100523667ea4c1d2be60c15a4bf35ec931ded9e1181a4545bbaa9b96fb27d0dd SHA512 baad9d2229ac289c4eb1d6e64bac0313efd4680f42a95270e0c1141d511392e6a95a5fea767943ddf432f5f0d48d95a05bbf26e06df188079ac177d321e4fa5c
diff --git a/dev-python/typish/metadata.xml b/dev-python/typish/metadata.xml
new file mode 100644
index 000000000..4febcc126
--- /dev/null
+++ b/dev-python/typish/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">typish</remote-id>
+ <remote-id type="github">ramonhagenaars/typish</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/typish/typish-1.9.3.ebuild b/dev-python/typish/typish-1.9.3.ebuild
new file mode 100644
index 000000000..f471f6836
--- /dev/null
+++ b/dev-python/typish/typish-1.9.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python functions for thorough checks on types"
+HOMEPAGE="https://pypi.org/project/typish"
+
+# Prefer GitHub. Upstream failed to push its source tarball to PyPI.
+SRC_URI="https://github.com/ramonhagenaars/typish/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#FIXME: Tests require "nptyping" which circularly requires... "typish". *sigh*
+RESTRICT="test"