aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2024-01-25 02:05:37 -0500
committerHorea Christian <chr@chymera.eu>2024-01-25 02:05:37 -0500
commit55997c153d133ed9db670215e9cb405ff92404f9 (patch)
treeb8128f6f8dcd75392a36fe8e8ac66057b3b35b6b /dev-vcs
parentsci-biology/SPAdes: added comment for next release (diff)
downloadsci-55997c153d133ed9db670215e9cb405ff92404f9.tar.gz
sci-55997c153d133ed9db670215e9cb405ff92404f9.tar.bz2
sci-55997c153d133ed9db670215e9cb405ff92404f9.zip
dev-vcs/dandi-cli: add 0.59.0
Signed-off-by: Horea Christian <chr@chymera.eu>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/dandi-cli/Manifest1
-rw-r--r--dev-vcs/dandi-cli/dandi-cli-0.59.0.ebuild89
-rw-r--r--dev-vcs/dandi-cli/files/dandi-cli-0.59.0-no-etelemetry.patch40
-rw-r--r--dev-vcs/dandi-cli/files/dandi-cli-0.59.0-typo.patch12
4 files changed, 142 insertions, 0 deletions
diff --git a/dev-vcs/dandi-cli/Manifest b/dev-vcs/dandi-cli/Manifest
index d249e7c33..8ac0c5717 100644
--- a/dev-vcs/dandi-cli/Manifest
+++ b/dev-vcs/dandi-cli/Manifest
@@ -1,3 +1,4 @@
DIST dandi-0.51.0.tar.gz 233955 BLAKE2B 500a6290cba32f413610879357c0ee525d877575c4ad520818a556ae7f58f90c2aec88387dbb0ca78e7906b48673c2c2d3c9c457833727fb312e5ca6d75ce088 SHA512 e77fa803dd2707df8cab2318377a71c28abb8bdc6e2d086cb43daf24512f361e533d249dabd88bfc6c0de06e6332606ac2f3c57482ae9717fedb66da4e2e8d89
DIST dandi-0.55.0.tar.gz 292471 BLAKE2B 2ccdba123c61025894a327d56163fd71cd0294b315b83396688903d969ba243fe2bb3ad9d2db5cf24d36254395a7de452d6e4ff4a65cf264f001a0cda527cd08 SHA512 e41f699a55cd75161048dd0e0334b84527ae0f4e02c81eedf7c8811b8bc50229488599f9601263e65a97fd815ce1d2cb41c94968fcc9ffde7726b72fe4e0180c
DIST dandi-0.55.1.tar.gz 296372 BLAKE2B 06d1b020bc3362f64779da8a4d229c9919c1edee83b530bf248c7dfa591f97c10b08eb1e9cb2f54ec30d8e7a1bcc0ffe9ee8f925e0a51fb0ba3882699a605a33 SHA512 341f82b8b59ececf8addbb0a9087e2a5ace3b0c452d4da1d94c413daef594590d8350ba4421a077865a4eafbcefe4189478f385e8cfe0dd53a9e46c7782b3ce5
+DIST dandi-0.59.0.tar.gz 304436 BLAKE2B 7a2736cb8cebfc97ff3fe94414cd93652039803b15d87e1d9ac2b1c3f9650152ed56fbf787382977bb8c65d25f8ed02a7bd694dd92f20e55d737fb0572a33bed SHA512 79b650fe6d812244244522eed7bb2fe7d3ed67e953d67548ae5e538b70d431899b7b5254978890ddc60ca3a2f5c87f726f3f776019182abd4b30cc917e3b337e
diff --git a/dev-vcs/dandi-cli/dandi-cli-0.59.0.ebuild b/dev-vcs/dandi-cli/dandi-cli-0.59.0.ebuild
new file mode 100644
index 000000000..df160ad23
--- /dev/null
+++ b/dev-vcs/dandi-cli/dandi-cli-0.59.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+MY_PN="dandi"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="DANDI command line client to facilitate common operations"
+HOMEPAGE="https://github.com/dandi/dandi-cli"
+SRC_URI="$(pypi_sdist_url dandi)"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test etelemetry"
+
+RDEPEND="
+ =dev-python/dandi-schema-0.8*[${PYTHON_USEDEP}]
+ >=dev-python/pydantic-1.9.0[${PYTHON_USEDEP}]
+ >=sci-biology/bidsschematools-0.7.0[${PYTHON_USEDEP}]
+ dev-python/click-didyoumean[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/fscacher[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/interleave[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/keyrings-alt[${PYTHON_USEDEP}]
+ dev-python/nwbinspector[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/pynwb[${PYTHON_USEDEP}]
+ dev-python/pyout[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/semantic-version[${PYTHON_USEDEP}]
+ dev-python/tenacity[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/zarr[${PYTHON_USEDEP}]
+ dev-python/zarr_checksum[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/anys[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ media-libs/opencv[ffmpeg,${PYTHON_USEDEP}]
+ )
+"
+# Upstream might be amenable to dropping opencv:
+# https://github.com/dandi/dandi-cli/issues/944
+
+S="${WORKDIR}/${MY_P}"
+
+EPYTEST_DESELECT=(
+ # Reported upstream:
+ # https://github.com/dandi/dandi-cli/issues/1394
+ dandi/cli/tests/test_command.py::test_no_heavy_imports
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if use etelemetry; then
+ default
+ else
+ eapply "${FILESDIR}/${P}-no-etelemetry.patch"
+ default
+ fi
+}
+
+python_test() {
+ export DANDI_TESTS_NONETWORK=1
+ epytest
+}
diff --git a/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-no-etelemetry.patch b/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-no-etelemetry.patch
new file mode 100644
index 000000000..4d4f42a03
--- /dev/null
+++ b/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-no-etelemetry.patch
@@ -0,0 +1,40 @@
+diff --git a/dandi/files/bases.py b/dandi/files/bases.py
+index 45f5929f..38bde34f 100644
+--- a/dandi/files/bases.py
++++ b/dandi/files/bases.py
+@@ -18,7 +18,6 @@ from dandischema.digests.dandietag import DandiETag
+ from dandischema.models import BareAsset, CommonModel
+ from dandischema.models import Dandiset as DandisetMeta
+ from dandischema.models import get_schema_version
+-from etelemetry import get_project
+ from packaging.version import Version
+ from pydantic import ValidationError
+ import requests
+@@ -737,6 +736,7 @@ def _get_nwb_inspector_version():
+ _current_nwbinspector_version = get_package_version(name="nwbinspector")
+ # Ensure latest version of NWB Inspector is installed and used client-side
+ try:
++ from etelemetry import get_project
+ max_version = Version(
+ get_project(repo="NeurodataWithoutBorders/nwbinspector")["version"]
+ )
+diff --git a/setup.cfg b/setup.cfg
+--- a/setup.cfg 2024-01-09 14:08:33.952653200 -0500
++++ b/setup.cfg 2024-01-25 01:45:34.594335960 -0500
+@@ -34,7 +34,6 @@
+ click >= 7.1
+ click-didyoumean
+ dandischema ~= 0.8.0
+- etelemetry >= 0.2.2
+ fasteners
+ fscacher >= 0.3.0
+ hdmf != 3.5.0
+@@ -147,9 +146,6 @@
+ [mypy-click_didyoumean.*]
+ ignore_missing_imports = True
+
+-[mypy-etelemetry.*]
+-ignore_missing_imports = True
+-
+ [mypy-fasteners.*]
+ ignore_missing_imports = True
diff --git a/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-typo.patch b/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-typo.patch
new file mode 100644
index 000000000..57cbe6da2
--- /dev/null
+++ b/dev-vcs/dandi-cli/files/dandi-cli-0.59.0-typo.patch
@@ -0,0 +1,12 @@
+diff --git a/var/tmp/portage/dev-vcs/dandi-cli-0.59.0/work/dandi-0.59.0/setup.cfg b/tmp/setup.cfg
+index 13ed3f3..f855608 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -146,8 +146,6 @@ ignore_missing_imports = True
+ [mypy-click_didyoumean.*]
+ ignore_missing_imports = True
+
+-ignore_missing_imports = True
+-
+ [mypy-fasteners.*]
+ ignore_missing_imports = True