aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-10-06 23:33:19 +0200
committerMarius Brehler <marbre@linux.sungazer.de>2015-10-06 23:33:19 +0200
commit0ffbaf3d097c2600b921cdb7ff084ecfd0f3812e (patch)
tree197c42c103f246cffc2aed63dd693a171461a32a /sci-libs/arrayfire
parentdev-python/metakernel: Version bump (diff)
downloadsci-0ffbaf3d097c2600b921cdb7ff084ecfd0f3812e.tar.gz
sci-0ffbaf3d097c2600b921cdb7ff084ecfd0f3812e.tar.bz2
sci-0ffbaf3d097c2600b921cdb7ff084ecfd0f3812e.zip
sci-libs/arrayfire: Add nonfree use flag
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-libs/arrayfire')
-rw-r--r--sci-libs/arrayfire/ChangeLog3
-rw-r--r--sci-libs/arrayfire/arrayfire-9999.ebuild13
2 files changed, 11 insertions, 5 deletions
diff --git a/sci-libs/arrayfire/ChangeLog b/sci-libs/arrayfire/ChangeLog
index b369ea912..c12d9297d 100644
--- a/sci-libs/arrayfire/ChangeLog
+++ b/sci-libs/arrayfire/ChangeLog
@@ -1,6 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Id$
+ 06 Oct 2015; Marius Brehler <marbre@linux.sungazer.de> arrayfire-9999.ebuild:
+ sci-libs/arrayfire: Add nonfree use flag
+
*arrayfire-3.1.2 (27 Sep 2015)
27 Sep 2015; Marius Brehler <marbre@linux.sungazer.de>
diff --git a/sci-libs/arrayfire/arrayfire-9999.ebuild b/sci-libs/arrayfire/arrayfire-9999.ebuild
index 511aee3e1..fe86a2b0d 100644
--- a/sci-libs/arrayfire/arrayfire-9999.ebuild
+++ b/sci-libs/arrayfire/arrayfire-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit cmake-utils git-r3
+inherit cmake-utils git-r3 multilib
GTEST_PV="1.7.0"
@@ -14,9 +14,10 @@ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git git://github.com/${PN}/${PN}.g
SRC_URI="test? ( https://googletest.googlecode.com/files/gtest-${GTEST_PV}.zip )"
KEYWORDS=""
-LICENSE="BSD"
+LICENSE="BSD
+ nonfree? ( OpenSIFT )"
SLOT="0"
-IUSE="+examples +cpu cuda opencl test graphics"
+IUSE="+examples +cpu cuda nonfree opencl test graphics"
RDEPEND="
>=sys-devel/gcc-4.7:*
@@ -65,7 +66,9 @@ pkg_pretend() {
src_unpack() {
git-r3_src_unpack
- find "${WORKDIR}" -name "*_nonfree*" -delete || die
+ if ! use nonfree; then
+ find "${WORKDIR}" -name "*_nonfree*" -delete || die
+ fi
if use test; then
mkdir -p "${BUILD_DIR}"/third_party/src/ || die
@@ -89,7 +92,7 @@ src_configure() {
$(cmake-utils_use_build examples EXAMPLES)
$(cmake-utils_use_build test TEST)
$(cmake-utils_use_build graphics GRAPHICS)
- -DBUILD_NONFREE=OFF
+ $(cmake-utils_use_build nonfree NONFREE)
-DUSE_SYSTEM_BOOST_COMPUTE=ON
-DUSE_SYSTEM_CLBLAS=ON
-DUSE_SYSTEM_CLFFT=ON