aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-31 14:41:51 +0100
committerAisha Tammy <gentoo@aisha.cc>2020-12-31 13:54:20 +0000
commitb6aeb6766d4080589509466509a2450e7dcf81d6 (patch)
treeca31d213f3072079ec8b82dfd3f40bd2c78ba67e /sci-libs/spyking-circus
parentsci-libs/scikits_video: also add python3.9 (diff)
downloadsci-b6aeb6766d4080589509466509a2450e7dcf81d6.tar.gz
sci-b6aeb6766d4080589509466509a2450e7dcf81d6.tar.bz2
sci-b6aeb6766d4080589509466509a2450e7dcf81d6.zip
sci-libs/spyking-circus: version bump, bump py targets
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/sci/pull/1019 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'sci-libs/spyking-circus')
-rw-r--r--sci-libs/spyking-circus/Manifest3
-rw-r--r--sci-libs/spyking-circus/spyking-circus-0.9.6.ebuild39
-rw-r--r--sci-libs/spyking-circus/spyking-circus-1.0.6.ebuild (renamed from sci-libs/spyking-circus/spyking-circus-0.9.9.ebuild)12
3 files changed, 10 insertions, 44 deletions
diff --git a/sci-libs/spyking-circus/Manifest b/sci-libs/spyking-circus/Manifest
index 8375009a3..9e84f4a66 100644
--- a/sci-libs/spyking-circus/Manifest
+++ b/sci-libs/spyking-circus/Manifest
@@ -1,2 +1 @@
-DIST 0.9.6.tar.gz 4767942 BLAKE2B bb8c8c9374aeb61545accf1da08ed4ff6ab2b7d4ea138988ab22a4876718f36ec4056def94c27e050396f755b89268910c3ed6259a33aa2c106e704576476ebb SHA512 a5f42f9480a7fe2033440fe6bd7a8b13b7cfe985a8c7905102c6d30393f3e7f86ec8c783db67c6fc54ee8e16e449d21c752c05cfe114079c3b42c0065c0a8bed
-DIST 0.9.9.tar.gz 4773584 BLAKE2B 075f6200c86d68419a80330c54d80511c690ab23df0b13f5698b478a3ee98873c16a2abf433c02e8737e8afd434c95be3797bda86979d1069432e85087b47819 SHA512 d404dd35d7ca1001ca6d61216af00f67145dfad4f7a8d6324370d0a0f5fa44964ea2b9a41573521134f6ce30234a38ae7c0b59f0c41571297cd3dd65ec177885
+DIST 1.0.6.tar.gz 4814284 BLAKE2B 171aff57a6ab23c54c497f4486b3453666029aef27bb6c1051ddac2be4131d78e065d08feea9c193dd52cb6723db5bdd3aaacfe92cbdc7be35c90631957d4ded SHA512 908aea4f7c4fd47fdd9b67b70873708ae5dd5e461b12dbbe3b519ea058ce63235bede94800204d2e48dbde9bfed8b90c9f6bb40e93134bb8950f1b958103ecdf
diff --git a/sci-libs/spyking-circus/spyking-circus-0.9.6.ebuild b/sci-libs/spyking-circus/spyking-circus-0.9.6.ebuild
deleted file mode 100644
index 8c610c478..000000000
--- a/sci-libs/spyking-circus/spyking-circus-0.9.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast and scalable spike sorting in Python"
-HOMEPAGE="http://spyking-circus.rtfd.org"
-SRC_URI="https://github.com/spyking-circus/spyking-circus/archive/${PV}.tar.gz"
-
-LICENSE="CeCILL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/mpi4py[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- dev-python/blosc[${PYTHON_USEDEP}]
- dev-python/statsmodels[${PYTHON_USEDEP}]
-"
-DEPEND=""
-
-# Tests do not yet work as per upstream, also a qt5 dependency may need to be added for them in the future:
-# https://github.com/spyking-circus/spyking-circus/issues/234
-
-RESTRICT="test"
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}
diff --git a/sci-libs/spyking-circus/spyking-circus-0.9.9.ebuild b/sci-libs/spyking-circus/spyking-circus-1.0.6.ebuild
index ec6f5ee6c..b0881a38a 100644
--- a/sci-libs/spyking-circus/spyking-circus-0.9.9.ebuild
+++ b/sci-libs/spyking-circus/spyking-circus-1.0.6.ebuild
@@ -3,17 +3,20 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Fast spike sorting by template matching"
HOMEPAGE="https://github.com/spyking-circus/spyking-circus/"
SRC_URI="https://github.com/spyking-circus/spyking-circus/archive/${PV}.tar.gz"
-LICENSE="CeCILL-2"
+LICENSE="CeCILL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~x86"
+
+# TODO: Fix this
+RESTRICT="test"
RDEPEND="
>=dev-python/blosc-1.8[${PYTHON_USEDEP}]
@@ -32,3 +35,6 @@ RDEPEND="
|| ( <=sys-cluster/openmpi-3.0.0 >=sys-cluster/mpich-2.0 )
"
DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs_sphinx --no-autodoc
+distutils_enable_tests --install pytest