aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hdmf/hdmf-3.1.1-r1.ebuild')
-rw-r--r--dev-python/hdmf/hdmf-3.1.1-r1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/hdmf/hdmf-3.1.1-r1.ebuild b/dev-python/hdmf/hdmf-3.1.1-r1.ebuild
deleted file mode 100644
index b3f479f18..000000000
--- a/dev-python/hdmf/hdmf-3.1.1-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_10 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-DESCRIPTION="The Hierarchical Data Modeling Framework"
-HOMEPAGE="https://github.com/hdmf-dev/hdmf"
-SRC_URI="https://github.com/hdmf-dev/hdmf/releases/download/${PV}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- "
-BDEPEND=""
-
-distutils_enable_tests pytest
-
-# Known to upstream:
-# https://github.com/hdmf-dev/hdmf/issues/687
-EPYTEST_DESELECT=(
- tests/unit/utils_test/test_labelleddict.py::TestLabelledDict::test_set_key_attr
-)
-
-PATCHES=(
- "${FILESDIR}/${P}-versions.patch"
-)