aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/dandi-cli/files')
-rw-r--r--dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch30
-rw-r--r--dev-vcs/dandi-cli/files/dandi-cli-0.37.0-pep517.patch46
-rw-r--r--dev-vcs/dandi-cli/files/dandi-cli-0.37.0-pip-versioncheck.patch13
3 files changed, 0 insertions, 89 deletions
diff --git a/dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch b/dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch
deleted file mode 100644
index 6822e1abf..000000000
--- a/dev-vcs/dandi-cli/files/dandi-cli-0.28.0-no-etelemetry.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/dandi/utils.py 2021-09-21 11:51:39.799524534 -0400
-+++ b/dandi/utils.py 2021-10-06 04:58:00.506440719 -0400
-@@ -734,27 +734,4 @@
- def check_dandi_version():
- if os.environ.get("DANDI_NO_ET"):
- return
-- try:
-- import etelemetry
--
-- try:
-- etelemetry.check_available_version(
-- "dandi/dandi-cli", __version__, lgr=lgr, raise_exception=True
-- )
-- except etelemetry.client.BadVersionError:
-- # note: SystemExit is based of BaseException, so is not Exception
-- raise SystemExit(
-- "DANDI CLI has detected that you are using a version that is known to "
-- "contain bugs, is incompatible with our current data archive, or has "
-- "other significant performance limitations. "
-- "To continue using DANDI CLI, please upgrade your dandi client to a newer "
-- "version (e.g., using pip install --upgrade dandi if you installed using pip). "
-- "If you have any issues, please contact the DANDI "
-- "helpdesk at https://github.com/dandi/helpdesk/issues/new/choose ."
-- )
-- except Exception as exc:
-- lgr.warning(
-- "Failed to check for a more recent version available with etelemetry: %s",
-- exc,
-- )
- os.environ["DANDI_NO_ET"] = "1"
diff --git a/dev-vcs/dandi-cli/files/dandi-cli-0.37.0-pep517.patch b/dev-vcs/dandi-cli/files/dandi-cli-0.37.0-pep517.patch
deleted file mode 100644
index 4d4715f95..000000000
--- a/dev-vcs/dandi-cli/files/dandi-cli-0.37.0-pep517.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From a363b68b79b3dd2004912640c90958882a918537 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 4 May 2022 19:49:37 +0200
-Subject: [PATCH] Prepend to sys.path to fix versioneer in PEP517 mode
-
-Prepend the current directory to sys.path rather than appending it
-in order to fix the build in PEP517 mode properly. If the path
-is appended and versioneer is installed on the system, the system
-versioneer.py (i.e. the module used to install versioneer into projects)
-is imported rather than the local file, and the build fails:
-
-```
-Traceback (most recent call last):
- File "/usr/lib/python-exec/python3.10/gpep517", line 4, in <module>
- sys.exit(main())
- File "/usr/lib/python3.10/site-packages/gpep517/__main__.py", line 136, in main
- return func(args)
- File "/usr/lib/python3.10/site-packages/gpep517/__main__.py", line 44, in build_wheel
- wheel_name = backend.build_wheel(args.wheel_dir, args.config_json)
- File "/usr/lib/python3.10/site-packages/setuptools/build_meta.py", line 244, in build_wheel
- return self._build_with_temp_dir(['bdist_wheel'], '.whl',
- File "/usr/lib/python3.10/site-packages/setuptools/build_meta.py", line 229, in _build_with_temp_dir
- self.run_setup()
- File "/usr/lib/python3.10/site-packages/setuptools/build_meta.py", line 174, in run_setup
- exec(compile(code, __file__, 'exec'), locals())
- File "setup.py", line 32, in <module>
- "version": versioneer.get_version(),
-AttributeError: module 'versioneer' has no attribute 'get_version'
-```
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index e8dddc985..05765009c 100755
---- a/setup.py
-+++ b/setup.py
-@@ -23,7 +23,7 @@
- # This is needed for versioneer to be importable when building with PEP 517.
- # See <https://github.com/warner/python-versioneer/issues/193> and links
- # therein for more information.
--sys.path.append(os.path.dirname(__file__))
-+sys.path.insert(0, os.path.dirname(__file__))
-
- try:
- import versioneer
diff --git a/dev-vcs/dandi-cli/files/dandi-cli-0.37.0-pip-versioncheck.patch b/dev-vcs/dandi-cli/files/dandi-cli-0.37.0-pip-versioncheck.patch
deleted file mode 100644
index bcc3853d3..000000000
--- a/dev-vcs/dandi-cli/files/dandi-cli-0.37.0-pip-versioncheck.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/setup.cfg 2021-10-06 11:44:40.549337707 -0400
-+++ b/dsetup.cfg 2021-10-06 11:45:10.236935245 -0400
-@@ -30,8 +30,8 @@
- appdirs
- click
- click-didyoumean
-- dandischema ~= 0.6.0
-- etelemetry >= 0.2.2
-+ dandischema
-+ etelemetry
- fasteners
- fscacher
- # Specifying != might be what causes pip 19.3.1 first to install hdmf 1.5.1