aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/irstlm/files/irstlm-6.00.05-doc-obey-docdir.patch22
-rw-r--r--sci-misc/irstlm/files/irstlm-6.00.05-remove-lib-linking.patch18
-rw-r--r--sci-misc/irstlm/irstlm-6.00.05-r1.ebuild38
3 files changed, 78 insertions, 0 deletions
diff --git a/sci-misc/irstlm/files/irstlm-6.00.05-doc-obey-docdir.patch b/sci-misc/irstlm/files/irstlm-6.00.05-doc-obey-docdir.patch
new file mode 100644
index 000000000..0b25ead22
--- /dev/null
+++ b/sci-misc/irstlm/files/irstlm-6.00.05-doc-obey-docdir.patch
@@ -0,0 +1,22 @@
+Remove doc/irstlm-manual.pdf from install in --prefix to instead obey --docdir
+
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -1,5 +1,3 @@
+-documentationdir = @prefix@/doc
+-
+ if DOC_COMPILATION
+
+ irstlm-manual.pdf: irstlm-manual.tex
+@@ -14,10 +12,6 @@ clean-local:
+
+ all: irstlm-manual.pdf
+
+-dist_documentation_SCRIPTS = irstlm-manual.pdf
++dist_doc_DATA = irstlm-manual.pdf
+
+ endif
+-
+-EXTRA_DIST = irstlm-manual.tex
+-
+-
diff --git a/sci-misc/irstlm/files/irstlm-6.00.05-remove-lib-linking.patch b/sci-misc/irstlm/files/irstlm-6.00.05-remove-lib-linking.patch
new file mode 100644
index 000000000..c0cfcfe32
--- /dev/null
+++ b/sci-misc/irstlm/files/irstlm-6.00.05-remove-lib-linking.patch
@@ -0,0 +1,18 @@
+Remove Makefile.am lib linking operation
+Taken from upstream PR: https://github.com/irstlm-team/irstlm/pull/12
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -7,12 +7,3 @@ SUBDIRS = src scripts doc
+ EXTRA_DIST = README RELEASE Copyright
+
+ ACLOCAL_AMFLAGS = -I m4
+-
+-LN_S=@LN_S@
+-
+-install-exec-hook:
+- cd ${exec_prefix}/ && \
+- ${LN_S} -n -f lib lib64
+-
+-dist-hook:
+- rm -rf `find $(distdir)/doc -type d -name .svn`
diff --git a/sci-misc/irstlm/irstlm-6.00.05-r1.ebuild b/sci-misc/irstlm/irstlm-6.00.05-r1.ebuild
new file mode 100644
index 000000000..73786fd4a
--- /dev/null
+++ b/sci-misc/irstlm/irstlm-6.00.05-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A tool to estimate, store, and access very large n-gram language models"
+HOMEPAGE="https://hlt-mt.fbk.eu/technologies/irstlm"
+SRC_URI="https://github.com/irstlm-team/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc static-libs"
+
+BDEPEND="doc? ( app-text/texlive[extra] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-lib-linking.patch
+ "${FILESDIR}"/${P}-doc-obey-docdir.patch
+)
+
+src_prepare() {
+ default
+ # Remove AM_CXXFLAGS that are breaking the package or should not be there
+ # Bug: https://bugs.gentoo.org/755473
+ sed -e 's/-static -isystem\/usr\/include -W //' -i src/Makefile.am || die
+ # Needed for doc
+ cp "${S}/doc/RELEASE" "${S}/RELEASE.tex" || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc)
+}