summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Schultz (mschultz) <mattsch@gmail.com>2009-11-24 19:03:51 +0000
committerMatthew Schultz (mschultz) <mattsch@gmail.com>2009-11-24 19:03:51 +0000
commitec553f95b22ef5085d192f92d19e76a5b1027eb3 (patch)
tree8ef10dfea665e831565a043570c18d373b9cddcf /dev-java
parentRemoving selenium-remote-control to make way for the binary named version. (diff)
downloadsunrise-ec553f95b22ef5085d192f92d19e76a5b1027eb3.tar.gz
sunrise-ec553f95b22ef5085d192f92d19e76a5b1027eb3.tar.bz2
sunrise-ec553f95b22ef5085d192f92d19e76a5b1027eb3.zip
dev-java/selenium-remote-control-bin: New ebuild for bug 294308
svn path=/sunrise/; revision=9602
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/selenium-remote-control-bin/ChangeLog8
-rw-r--r--dev-java/selenium-remote-control-bin/Manifest4
-rw-r--r--dev-java/selenium-remote-control-bin/metadata.xml6
-rw-r--r--dev-java/selenium-remote-control-bin/selenium-remote-control-bin-1.0.1.ebuild41
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-java/selenium-remote-control-bin/ChangeLog b/dev-java/selenium-remote-control-bin/ChangeLog
new file mode 100644
index 000000000..8c5234803
--- /dev/null
+++ b/dev-java/selenium-remote-control-bin/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-java/selenium-remote-control-bin
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 24 Nov 2009; Matthew Schultz (mschultz) <mattsch@gmail.com>
+ +selenium-remote-control-bin-1.0.1.ebuild, +metadata.xml:
+ New ebuild for bug 294308
+
diff --git a/dev-java/selenium-remote-control-bin/Manifest b/dev-java/selenium-remote-control-bin/Manifest
new file mode 100644
index 000000000..ba122d3dd
--- /dev/null
+++ b/dev-java/selenium-remote-control-bin/Manifest
@@ -0,0 +1,4 @@
+DIST selenium-remote-control-1.0.1-dist.zip 10971251 RMD160 45489db4da85a248c06d8cb963777b1e51319ece SHA1 b79605f790d801cc553666bf7d61b94c6d535d9f SHA256 e8c4e50c99c774cbc25d96452af272232dab23273e086c96ed83ceec6bdf79a0
+EBUILD selenium-remote-control-bin-1.0.1.ebuild 1156 RMD160 b237def4a66e3965fe99fc66c13a757e9e77e6ea SHA1 142e940c440e8ed601f56447ffae83d196b90b82 SHA256 2a6eaf1993e4215bf2a548e2da50cb1002247c3f5515a70a80f07a6651afe991
+MISC ChangeLog 288 RMD160 7db3e7ed7f1c8443a336cdee2fa8aa32c01c2ab7 SHA1 f91d6475601111af4b0466eb61b5c6eba2e73f8d SHA256 aae926f55b63bd175f743a0b33921947acafca2212f10cb0512a2bec7a0872c9
+MISC metadata.xml 320 RMD160 b85b169bd957a751e3e32b5f661ecc35261d3a32 SHA1 003627782e9ee4322d83641835a6284d98d01e5c SHA256 ad31a50e8761c9175377fdcc54abcf0a720ac3bce58355133da6009454eeadc9
diff --git a/dev-java/selenium-remote-control-bin/metadata.xml b/dev-java/selenium-remote-control-bin/metadata.xml
new file mode 100644
index 000000000..fd76cd45c
--- /dev/null
+++ b/dev-java/selenium-remote-control-bin/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <longdescription>A server which automatically launches and kills browsers, and acts as a HTTP proxy for web requests from them.</longdescription>
+</pkgmetadata>
diff --git a/dev-java/selenium-remote-control-bin/selenium-remote-control-bin-1.0.1.ebuild b/dev-java/selenium-remote-control-bin/selenium-remote-control-bin-1.0.1.ebuild
new file mode 100644
index 000000000..b014f0a15
--- /dev/null
+++ b/dev-java/selenium-remote-control-bin/selenium-remote-control-bin-1.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit java-pkg-2
+
+MY_P="${P/-bin/}"
+MY_PN="${PN/-bin/}"
+
+DESCRIPTION="Web application testing toolkit utilizing remote-control of a web browser"
+HOMEPAGE="http://seleniumhq.org/projects/remote-control/"
+SRC_URI="http://release.seleniumhq.org/${MY_PN}/${PV}/${MY_P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5
+ x11-libs/libX11"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ java-pkg_newjar "${S}"/selenium-server-${PV}/selenium-server.jar
+ java-pkg_dolauncher
+}
+
+pkg_postinst() {
+ einfo "You will need a browser that selenium remote control can"
+ einfo "start and run tests. The list of supported browsers can"
+ einfo "be found here:"
+ einfo "http://seleniumhq.org/about/platforms.html#browsers"
+ einfo ""
+ einfo "Note that you must start selenium remote control within"
+ einfo "an X session of the user you intend run selenium scripts on."
+ einfo ""
+ einfo "You can use /usr/bin/selenium-remote-control-bin to start the"
+ einfo "selenium remote control."
+}