summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2009-10-23 16:39:55 +0200
committerSebastian Pipping <sebastian@pipping.org>2009-10-23 16:39:55 +0200
commiteda035948a6b35edadfbb8ac8e810d6ee6886469 (patch)
treec34debaa80be251a8f0977f35eda935a105261ee /net-zope
parentSet repo_name (diff)
downloadturbogears2-eda035948a6b35edadfbb8ac8e810d6ee6886469.tar.gz
turbogears2-eda035948a6b35edadfbb8ac8e810d6ee6886469.tar.bz2
turbogears2-eda035948a6b35edadfbb8ac8e810d6ee6886469.zip
Add ebuilds from sping overlay
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/z3c-recipe-sphinxdoc/Manifest2
-rw-r--r--net-zope/z3c-recipe-sphinxdoc/z3c-recipe-sphinxdoc-0.0.8.ebuild25
-rw-r--r--net-zope/zopecomponent/Manifest2
-rw-r--r--net-zope/zopecomponent/zopecomponent-3.6.0.ebuild27
-rw-r--r--net-zope/zopeconfiguration/Manifest2
-rw-r--r--net-zope/zopeconfiguration/zopeconfiguration-3.6.0.ebuild25
-rw-r--r--net-zope/zopei18n/Manifest2
-rw-r--r--net-zope/zopei18n/zopei18n-3.7.0.ebuild27
-rw-r--r--net-zope/zopei18nmessageid/Manifest2
-rw-r--r--net-zope/zopei18nmessageid/zopei18nmessageid-3.4.3.ebuild22
-rw-r--r--net-zope/zopeschema/Manifest2
-rw-r--r--net-zope/zopeschema/zopeschema-3.5.4.ebuild26
-rw-r--r--net-zope/zopesqlalchemy/Manifest2
-rw-r--r--net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild28
14 files changed, 194 insertions, 0 deletions
diff --git a/net-zope/z3c-recipe-sphinxdoc/Manifest b/net-zope/z3c-recipe-sphinxdoc/Manifest
new file mode 100644
index 0000000..3de6b6e
--- /dev/null
+++ b/net-zope/z3c-recipe-sphinxdoc/Manifest
@@ -0,0 +1,2 @@
+DIST z3c.recipe.sphinxdoc-0.0.8.tar.gz 12642 RMD160 0d6ff3a20ef43c3a1315f093e932b3202b1fcc90 SHA1 239d8fc0c4311c3fccf3dc69e33e7e16efedd483 SHA256 abd66c69fc91877a4b7616985b15b0e8dd6e213efda8c2ae71bfa59e1129422a
+EBUILD z3c-recipe-sphinxdoc-0.0.8.ebuild 631 RMD160 a87b50782d345903cacdbd2e1309238bfefe5fe7 SHA1 ca71ab675cbe392fbff9d6d7c2142bef1a9aa151 SHA256 40574f61b9505e954b72afb58203c4c001da3dda3d9ae03e8e324f897edf691c
diff --git a/net-zope/z3c-recipe-sphinxdoc/z3c-recipe-sphinxdoc-0.0.8.ebuild b/net-zope/z3c-recipe-sphinxdoc/z3c-recipe-sphinxdoc-0.0.8.ebuild
new file mode 100644
index 0000000..debe41c
--- /dev/null
+++ b/net-zope/z3c-recipe-sphinxdoc/z3c-recipe-sphinxdoc-0.0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+
+inherit distutils
+
+MY_PN="z3c.recipe.sphinxdoc"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Use Sphinx to build documentation for zope.org."
+HOMEPAGE="http://pypi.python.org/pypi/z3c.recipe.sphinxdoc/"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="ZPL"
+KEYWORDS=""
+SLOT="0"
+IUSE=""
+
+RDEPEND="net-zope/zcbuildout
+ dev-python/zc-recipe-egg
+ dev-python/sphinx"
+DEPEND="dev-python/setuptools
+ dev-python/docutils"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/net-zope/zopecomponent/Manifest b/net-zope/zopecomponent/Manifest
new file mode 100644
index 0000000..50dfe28
--- /dev/null
+++ b/net-zope/zopecomponent/Manifest
@@ -0,0 +1,2 @@
+DIST zope.component-3.6.0.tar.gz 87857 RMD160 879feda3b8cc4bc27bb946ec5caf74fa661da0b2 SHA1 122ee25ffeb3e8145a88fb7ab8165c258ad189b7 SHA256 b83381b4c2c74721f3c94cc9e03e62c4ac620f979a332baba3f70bf951f7e65f
+EBUILD zopecomponent-3.6.0.ebuild 627 RMD160 9213f6a63ed69e979c0cc6829cc5d30193962835 SHA1 c292e73c8acab7dfcde7d3dff20d350af51a3a51 SHA256 c83a36f798ca9323101f3d228f0b7a2e2f345feacb76d12e8666d3841268bddb
diff --git a/net-zope/zopecomponent/zopecomponent-3.6.0.ebuild b/net-zope/zopecomponent/zopecomponent-3.6.0.ebuild
new file mode 100644
index 0000000..8c5b8a9
--- /dev/null
+++ b/net-zope/zopecomponent/zopecomponent-3.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+MY_PN="zope.component"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Component Architecture"
+HOMEPAGE="http://pypi.python.org/pypi/zope.component"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE=""
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="net-zope/zopedeprecation
+ net-zope/zopeinterface
+ net-zope/zopedeferredimport
+ net-zope/zopeevent"
+DEPEND="dev-python/setuptools
+ test? ( net-zope/zopetesting )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README.txt"
diff --git a/net-zope/zopeconfiguration/Manifest b/net-zope/zopeconfiguration/Manifest
new file mode 100644
index 0000000..a9fe988
--- /dev/null
+++ b/net-zope/zopeconfiguration/Manifest
@@ -0,0 +1,2 @@
+DIST zope.configuration-3.6.0.tar.gz 48133 RMD160 e2f7c2b2d12291c5a664c308d486bf85d2250eda SHA1 3dabbe682871fa83b49b1308e64a36aa9692707f SHA256 a18e57267562da177825a23f3ab6304b7aafc904b9c3799761f07c0925a079f5
+EBUILD zopeconfiguration-3.6.0.ebuild 636 RMD160 2f6b3f77ff231b866c7f6f8deb0b4636dfb32c44 SHA1 90ea698f55b9750c6278fa212ec1245b40113d0a SHA256 349d67685fb186079d6c03e96662000ed699fb7496ab479a4f747a6b2841e749
diff --git a/net-zope/zopeconfiguration/zopeconfiguration-3.6.0.ebuild b/net-zope/zopeconfiguration/zopeconfiguration-3.6.0.ebuild
new file mode 100644
index 0000000..abb3181
--- /dev/null
+++ b/net-zope/zopeconfiguration/zopeconfiguration-3.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+
+inherit distutils
+
+MY_PN="${PN/zope/zope.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Configuration Markup Language (ZCML)"
+HOMEPAGE="http://pypi.python.org/pypi/zope.configuration"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="ZPL"
+KEYWORDS=""
+SLOT="0"
+IUSE=""
+
+RDEPEND="net-zope/zopei18nmessageid
+ net-zope/zopeinterface
+ net-zope/zopeschema"
+DEPEND="dev-python/setuptools
+ test? ( net-zope/zopetesting )"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/net-zope/zopei18n/Manifest b/net-zope/zopei18n/Manifest
new file mode 100644
index 0000000..6b78ae5
--- /dev/null
+++ b/net-zope/zopei18n/Manifest
@@ -0,0 +1,2 @@
+DIST zope.i18n-3.7.0.tar.gz 598395 RMD160 9ea274e6c05e332c23277c8bd1040367507c7471 SHA1 57ff88e777ef114b347b89d294d004e9e837e4f7 SHA256 fc717953c3ab05496cbdc7634fb5234733a04ffed5655a8c128f254a1012e9e0
+EBUILD zopei18n-3.7.0.ebuild 660 RMD160 69b5ec1f90388e67cbd5cadb05b78d6ccaa58958 SHA1 23d6a2989751cd977a7d5d700d14ceaf2280c4f7 SHA256 70c4b942fb5eb5b68215d68cff2612566182f47b869457134d40e64fd2a4dc4b
diff --git a/net-zope/zopei18n/zopei18n-3.7.0.ebuild b/net-zope/zopei18n/zopei18n-3.7.0.ebuild
new file mode 100644
index 0000000..cb8b7ed
--- /dev/null
+++ b/net-zope/zopei18n/zopei18n-3.7.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+
+inherit distutils
+
+MY_PN="${PN/zope/zope.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope3 Internationalization Support"
+HOMEPAGE="http://pypi.python.org/pypi/zope.i18n"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="ZPL"
+KEYWORDS=""
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pytz
+ net-zope/zopeschema
+ net-zope/zopei18nmessageid
+ net-zope/zopecomponent
+ net-zope/zopeconfiguration
+ dev-python/python-gettext"
+DEPEND="dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/net-zope/zopei18nmessageid/Manifest b/net-zope/zopei18nmessageid/Manifest
new file mode 100644
index 0000000..d521c45
--- /dev/null
+++ b/net-zope/zopei18nmessageid/Manifest
@@ -0,0 +1,2 @@
+DIST zope.i18nmessageid-3.4.3.tar.gz 8688 RMD160 850cea792d8bf1e5c344d282deb968aab1c7649d SHA1 30de59a9fbd1ee4797d9dd21c80d8427853c15bf SHA256 af6ea7240d54c5488539496f7c9e1a1e9e991ee9573b61cc38f691612f3fc287
+EBUILD zopei18nmessageid-3.4.3.ebuild 522 RMD160 9572338663afb33d7e38e6d91365e0605128ace4 SHA1 1ebaff56999cb264d636f735806b40f9590fd4af SHA256 c5a18934dc92707f409ebfdd7850db23fdc1819638b2379cc1362bb1ea41d2f8
diff --git a/net-zope/zopei18nmessageid/zopei18nmessageid-3.4.3.ebuild b/net-zope/zopei18nmessageid/zopei18nmessageid-3.4.3.ebuild
new file mode 100644
index 0000000..87f76e6
--- /dev/null
+++ b/net-zope/zopei18nmessageid/zopei18nmessageid-3.4.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+
+inherit distutils
+
+MY_PN="${PN/zope/zope.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope 3 i18n Message Identifier"
+HOMEPAGE="http://pypi.python.org/pypi/zope.i18nmessageid"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="ZPL"
+KEYWORDS=""
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/net-zope/zopeschema/Manifest b/net-zope/zopeschema/Manifest
new file mode 100644
index 0000000..bff74bd
--- /dev/null
+++ b/net-zope/zopeschema/Manifest
@@ -0,0 +1,2 @@
+DIST zope.schema-3.5.4.tar.gz 61380 RMD160 c8645f71d417c0a514264a3f0f824564b3129b13 SHA1 962efba146b18fba31d51225e97170f7da60aa80 SHA256 e825cfc10801e8f05e226e691d25092ec2888525728b981167886db38b84ca84
+EBUILD zopeschema-3.5.4.ebuild 680 RMD160 e38dde35fcf266b5851441fe5e1b08b2d2f15576 SHA1 865b6f5256666ad0393b30b984909445b9feadb2 SHA256 a9fcbb37dcd72868467fc7d48959739319b660949908a2e29c3bfb9181b7fd77
diff --git a/net-zope/zopeschema/zopeschema-3.5.4.ebuild b/net-zope/zopeschema/zopeschema-3.5.4.ebuild
new file mode 100644
index 0000000..51d3bfe
--- /dev/null
+++ b/net-zope/zopeschema/zopeschema-3.5.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+
+inherit distutils
+
+MY_PN="zope.schema"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="zope.interface extension for defining data schemas"
+HOMEPAGE="http://pypi.python.org/pypi/zope.schema"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="ZPL"
+KEYWORDS=""
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="net-zope/zopei18nmessageid
+ net-zope/zopeinterface
+ net-zope/zopeevent"
+DEPEND="dev-python/setuptools
+ test? ( net-zope/zopetesting )
+ doc? ( net-zope/z3c-recipe-sphinxdoc )"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/net-zope/zopesqlalchemy/Manifest b/net-zope/zopesqlalchemy/Manifest
new file mode 100644
index 0000000..a562566
--- /dev/null
+++ b/net-zope/zopesqlalchemy/Manifest
@@ -0,0 +1,2 @@
+DIST zope.sqlalchemy-0.4.tar.gz 13136 RMD160 2ec58c8445ae266c80c51a88f0934947d5a931f9 SHA1 053176396befc6cb4b8e674d6f47f8cd5106e320 SHA256 96fa5dd6e262f52904ee8431bf9d57c27f3dc63581a02d233f2ae4cda202ed1d
+EBUILD zopesqlalchemy-0.4.ebuild 743 RMD160 3b742e2c30880de5783ddb46a49d907c4844480a SHA1 785bd9688d716275ca85ab4f485bb2a4e9796e70 SHA256 342715ca3e365893a0fd12fd1ae8dc66f961cc5d3736bf980ffe2a375e098a0a
diff --git a/net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild b/net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild
new file mode 100644
index 0000000..7f3281b
--- /dev/null
+++ b/net-zope/zopesqlalchemy/zopesqlalchemy-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+
+inherit distutils
+
+MY_PN="${PN/zope/zope.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Minimal Zope/SQLAlchemy transaction integration"
+HOMEPAGE="http://pypi.python.org/pypi/zope.sqlalchemy"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="ZPL"
+KEYWORDS=""
+SLOT="0"
+IUSE="test"
+
+RDEPEND="|| (
+ ( >=dev-python/sqlalchemy-0.4.7 <=dev-python/sqlalchemy-0.5 )
+ >=dev-python/sqlalchemy-0.5.1
+ )
+ dev-python/transaction
+ net-zope/zopeinterface"
+DEPEND="dev-python/setuptools
+ test? ( net-zope/zopetesting dev-python/docutils )"
+
+S="${WORKDIR}/${MY_P}"