summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Rossi <rossi.f@inwind.it>2017-03-20 00:28:33 +0100
committerFabio Rossi <rossi.f@inwind.it>2017-03-20 00:28:33 +0100
commit7ff2b1ee0be047a702e08dfb68a43b5e4b258ef7 (patch)
tree02dc4af4ab4b8d812fae7a5429c106ed770566b3 /app-emulation/vmware-modules
parentapp-emulation/vmware-player: add missing rc file (diff)
downloadvmware-7ff2b1ee0be047a702e08dfb68a43b5e4b258ef7.tar.gz
vmware-7ff2b1ee0be047a702e08dfb68a43b5e4b258ef7.tar.bz2
vmware-7ff2b1ee0be047a702e08dfb68a43b5e4b258ef7.zip
Added latest version 12.5.4.5192485
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/files/308-4.09-00-user-pages-p1.patch (renamed from app-emulation/vmware-modules/files/308-4.09-00-user-pages.patch)26
-rw-r--r--app-emulation/vmware-modules/files/308-4.09-00-user-pages-p2.patch26
-rw-r--r--app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild3
-rw-r--r--app-emulation/vmware-modules/vmware-modules-308.5.4.ebuild (renamed from app-emulation/vmware-modules/vmware-modules-308.5.2.ebuild)2
4 files changed, 29 insertions, 28 deletions
diff --git a/app-emulation/vmware-modules/files/308-4.09-00-user-pages.patch b/app-emulation/vmware-modules/files/308-4.09-00-user-pages-p1.patch
index 1790f73..28758f7 100644
--- a/app-emulation/vmware-modules/files/308-4.09-00-user-pages.patch
+++ b/app-emulation/vmware-modules/files/308-4.09-00-user-pages-p1.patch
@@ -37,29 +37,3 @@
retval = get_user_pages(addr, 1, 1, 0, &page, NULL);
#else
retval = get_user_pages(current, current->mm, addr,
---- ./vmnet-only/userif.c 2017-02-23 12:29:00.909852764 +0100
-+++ ./vmnet-only/userif.c.new 2017-02-23 12:28:51.309852227 +0100
-@@ -113,7 +113,9 @@
- int retval;
-
- down_read(&current->mm->mmap_sem);
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
-+ retval = get_user_pages(addr, 1, FOLL_WRITE, &page, NULL);
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
- retval = get_user_pages(addr, 1, 1, 0, &page, NULL);
- #else
- retval = get_user_pages(current, current->mm, addr,
---- ./vmmon-only/linux/hostif.c 2017-02-23 12:19:59.772822506 +0100
-+++ ./vmmon-only/linux/hostif.c.new 2017-02-23 12:26:42.661845034 +0100
-@@ -1167,7 +1167,9 @@
- int retval;
-
- down_read(&current->mm->mmap_sem);
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
-+ retval = get_user_pages((unsigned long)uvAddr, numPages, 0, ppages, NULL);
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
- retval = get_user_pages((unsigned long)uvAddr, numPages, 0, 0, ppages, NULL);
- #else
- retval = get_user_pages(current, current->mm, (unsigned long)uvAddr,
diff --git a/app-emulation/vmware-modules/files/308-4.09-00-user-pages-p2.patch b/app-emulation/vmware-modules/files/308-4.09-00-user-pages-p2.patch
new file mode 100644
index 0000000..5c4c869
--- /dev/null
+++ b/app-emulation/vmware-modules/files/308-4.09-00-user-pages-p2.patch
@@ -0,0 +1,26 @@
+--- ./vmnet-only/userif.c 2017-02-23 12:29:00.909852764 +0100
++++ ./vmnet-only/userif.c.new 2017-02-23 12:28:51.309852227 +0100
+@@ -113,7 +113,9 @@
+ int retval;
+
+ down_read(&current->mm->mmap_sem);
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
++ retval = get_user_pages(addr, 1, FOLL_WRITE, &page, NULL);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
+ retval = get_user_pages(addr, 1, 1, 0, &page, NULL);
+ #else
+ retval = get_user_pages(current, current->mm, addr,
+--- ./vmmon-only/linux/hostif.c 2017-02-23 12:19:59.772822506 +0100
++++ ./vmmon-only/linux/hostif.c.new 2017-02-23 12:26:42.661845034 +0100
+@@ -1167,7 +1167,9 @@
+ int retval;
+
+ down_read(&current->mm->mmap_sem);
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 9, 0)
++ retval = get_user_pages((unsigned long)uvAddr, numPages, 0, ppages, NULL);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 6, 0)
+ retval = get_user_pages((unsigned long)uvAddr, numPages, 0, 0, ppages, NULL);
+ #else
+ retval = get_user_pages(current, current->mm, (unsigned long)uvAddr,
diff --git a/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild b/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
index 1e4eebb..51eaa63 100644
--- a/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
@@ -106,7 +106,8 @@ src_prepare() {
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.07-00-trans_start.patch"
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.07-01-readlink_copy.patch"
kernel_is ge 4 8 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.08-00-nr_anon_mapped.patch"
- kernel_is ge 4 9 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.09-00-user-pages.patch"
+ kernel_is ge 4 9 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.09-00-user-pages-p1.patch"
+ kernel_is ge 4 9 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.09-00-user-pages-p2.patch"
kernel_is ge 4 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.10-00-generic_readlink.patch"
# Allow user patches so they can support RC kernels and whatever else
diff --git a/app-emulation/vmware-modules/vmware-modules-308.5.2.ebuild b/app-emulation/vmware-modules/vmware-modules-308.5.4.ebuild
index 75e0f06..4fcb06c 100644
--- a/app-emulation/vmware-modules/vmware-modules-308.5.2.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-308.5.4.ebuild
@@ -104,7 +104,7 @@ src_prepare() {
kernel_is ge 4 6 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.06-00-user-pages-p2.patch"
kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.07-01-readlink_copy.patch"
kernel_is ge 4 8 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.08-00-nr_anon_mapped.patch"
- kernel_is ge 4 9 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.09-00-user-pages.patch"
+ kernel_is ge 4 9 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.09-00-user-pages-p1.patch"
kernel_is ge 4 10 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.10-00-generic_readlink.patch"
# Allow user patches so they can support RC kernels and whatever else