summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/siproxd/ChangeLog8
-rw-r--r--net-misc/siproxd/Manifest5
-rw-r--r--net-misc/siproxd/files/siproxd-0.5.11-configure-docs.diff28
-rw-r--r--net-misc/siproxd/siproxd-0.6.0.ebuild64
4 files changed, 105 insertions, 0 deletions
diff --git a/net-misc/siproxd/ChangeLog b/net-misc/siproxd/ChangeLog
new file mode 100644
index 0000000..3665803
--- /dev/null
+++ b/net-misc/siproxd/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-misc/siproxd
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 14 Dec 2007; Chi-Thanh Christopher Nguyen <chithanh@cs.tu-berlin.de>
+ +files/siproxd-0.5.11-configure-docs.diff, +siproxd-0.6.0.ebuild:
+ New version. Don't use system installed libosip because of incompatibility
+ with >=libosip-3
diff --git a/net-misc/siproxd/Manifest b/net-misc/siproxd/Manifest
new file mode 100644
index 0000000..e0c0a70
--- /dev/null
+++ b/net-misc/siproxd/Manifest
@@ -0,0 +1,5 @@
+AUX siproxd-0.5.11-configure-docs.diff 1023 RMD160 de2450728a1eca0cda4c69223885489464943599 SHA1 2c66a464231efb0b2198b5341a5c0ae5545b198b SHA256 363e714a7a16a950862c30cbaa3060c27eda7260e3200981280b4c1c0d56ff70
+DIST libosip2-2.2.2.tar.gz 664050 RMD160 49aaba3bb0f1483dca02dc5b6103f42e239c2527 SHA1 493d0ff3ba07056a8833a798cd6f9018841e3e91 SHA256 4e13febd65a2f8f18cb55151cd10f5f0888bf1e7dc2a4c0d54f39f170255de1c
+DIST siproxd-0.6.0.tar.gz 244459 RMD160 4c3f9746b41feae5a20b346cd02c31e7246fa144 SHA1 ae5f6a61356a95260770cf7d5a2a839a6aa37a0f SHA256 a12b6f5b6ed8ee85d17105b97c0dcb48b0417ae7efa48c5b67f10993b595086c
+EBUILD siproxd-0.6.0.ebuild 1500 RMD160 014ed188857f6e588b5461cd8c89a44079f61254 SHA1 978c84978ed9727c122500337c9cb669ce5af05a SHA256 3a87b11325332eb3c58db0b61f6c9b789da4b7c3320cf02fec23ae012a00186f
+MISC ChangeLog 352 RMD160 d0d76a6ef3fde881ca7f45ee7893fa3384da1462 SHA1 907027029dbc173f16dabba64b0ef63c3a1a2d32 SHA256 72b01ab98a52360564f3199be08b63fd1da9c34a40ec7e260c83beb4406c301f
diff --git a/net-misc/siproxd/files/siproxd-0.5.11-configure-docs.diff b/net-misc/siproxd/files/siproxd-0.5.11-configure-docs.diff
new file mode 100644
index 0000000..1ba0ad3
--- /dev/null
+++ b/net-misc/siproxd/files/siproxd-0.5.11-configure-docs.diff
@@ -0,0 +1,28 @@
+--- siproxd-0.5.11/configure.in.orig 2005-05-07 16:43:13.333858336 +0200
++++ siproxd-0.5.11/configure.in 2005-05-07 16:52:22.980299376 +0200
+@@ -72,10 +72,21 @@
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+-AC_CHECK_PROG(docbook2pdf,docbook2pdf,yes,)
+-AM_CONDITIONAL(have_docbook2pdf,test "$docbook2pdf" = "yes")
+-AC_CHECK_PROG(docbook2html,docbook2html,yes,)
+-AM_CONDITIONAL(have_docbook2html,test "$docbook2html" = "yes")
++
++AC_MSG_CHECKING(build statically linked executable)
++AC_ARG_ENABLE(docs,
++ [ --enable-docs build pdf/html documentation],
++ build_docs="$enableval";
++ AC_MSG_RESULT(yes), AC_MSG_RESULT(no))
++if test "x$build_docs" = "xyes"; then
++ AC_CHECK_PROG(docbook2pdf,docbook2pdf,yes,)
++ AM_CONDITIONAL(have_docbook2pdf,test "$docbook2pdf" = "yes")
++ AC_CHECK_PROG(docbook2html,docbook2html,yes,)
++ AM_CONDITIONAL(have_docbook2html,test "$docbook2html" = "yes")
++else
++ AM_CONDITIONAL(have_docbook2pdf,false)
++ AM_CONDITIONAL(have_docbook2html,false)
++fi
+
+ dnl
+ dnl add
diff --git a/net-misc/siproxd/siproxd-0.6.0.ebuild b/net-misc/siproxd/siproxd-0.6.0.ebuild
new file mode 100644
index 0000000..8811694
--- /dev/null
+++ b/net-misc/siproxd/siproxd-0.6.0.ebuild
@@ -0,0 +1,64 @@
+# $Header: $
+
+inherit eutils autotools
+
+OSIP_PN="libosip2"
+OSIP_PV="2.2.2"
+OSIP_P="${OSIP_PN}-${OSIP_PV}"
+DESCRIPTION="masquerading SIP proxy"
+HOMEPAGE="http://siproxd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/siproxd/${P}.tar.gz mirror://gnu/osip/${OSIP_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-text/docbook-sgml-utils ~app-text/docbook-sgml-dtd-4.2 )"
+
+pkg_setup() {
+ enewgroup siproxd
+ enewuser siproxd -1 -1 /dev/null siproxd
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.5.11-configure-docs.diff
+
+ eautoreconf || die "autoreconf failed"
+
+ # Make the daemon run as user 'siproxd' by default
+ sed -i -e "s:nobody:siproxd:" doc/siproxd.conf.example
+}
+
+src_compile() {
+ cd "../${OSIP_P}" || die
+ econf || die "osip configure failed"
+ emake || die "osip make failed"
+ emake DESTDIR="${T}" install || "osip install failed"
+
+ cd "${S}"
+ econf \
+ $(use_enable doc docs) \
+ --enable-static \
+ --with-libosip-prefix="${T}/usr" \
+ || die "configure failed"
+# siproxd will build statically, no matter whether --enable-static or
+# --disable static is passed to configure
+# $(use_enable static) \
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ newinitd "${FILESDIR}"/siproxd.rc6 siproxd
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO RELNOTES
+
+ # Set up siproxd directories
+ keepdir /var/{lib,run}/siproxd
+ fowners siproxd:siproxd /var/{lib,run}/siproxd
+}