summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-03 10:54:57 +0100
committerMichał Górny <mgorny@gentoo.org>2014-12-03 11:44:10 +0100
commit3383cdddf094227a9f5669c42929a3cde5f1e106 (patch)
tree441cb9b7bf582b253d14ed79c750a1ad276dc95e
parentsys-devel/gcc: fixes to install (diff)
downloadmgorny-3383cdddf094227a9f5669c42929a3cde5f1e106.tar.gz
mgorny-3383cdddf094227a9f5669c42929a3cde5f1e106.tar.bz2
mgorny-3383cdddf094227a9f5669c42929a3cde5f1e106.zip
sys-devel/gcc: clean up install, move gdb files to auto-load
Package-Manager: portage-2.2.14
-rw-r--r--sys-devel/gcc/gcc-4.9.2-r100.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.9.2-r100.ebuild b/sys-devel/gcc/gcc-4.9.2-r100.ebuild
index d0b386f..c61809d 100644
--- a/sys-devel/gcc/gcc-4.9.2-r100.ebuild
+++ b/sys-devel/gcc/gcc-4.9.2-r100.ebuild
@@ -557,12 +557,25 @@ src_install() {
# Punt some tools which are really only useful while building gcc
find "${D}" -name install-tools -prune -type d -exec rm -r {} + || die
+ # Some random 'dir' file?
+ rm "${D}${DATAPATH}"/info/dir || die
create_gcc_symlinks
strip_gcc_executables
+ # move *-gdb.py into /usr/share/gdb/auto-load tree
+ if use cxx; then
+ local py gdbdir=${D}usr/share/gdb/auto-load
+ while read -r -d '' py; do
+ mkdir -p "${gdbdir}/${py%/*}" || die
+ mv "${D}${py}" "${gdbdir}/${py%/*}"/ || die
+ done < <(cd "${D}" && find -name '*-gdb.py' -print0)
+ fi
+
if use cxx && use doc; then
cd "${WORKDIR}/build/${CTARGET}/libstdc++-v3/doc/doxygen/man" || die
+ # clean up some random files with build-dir paths
+ rm -f man*/*"${P}"*
cp -r man* "${D}${DATAPATH}"/man/ || die
fi