summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-26 13:29:17 +0200
committerMichał Górny <mgorny@gentoo.org>2014-08-26 13:29:17 +0200
commit9907fe41a2bc6fc8dbe825d226bccf714dd17b24 (patch)
tree62b38d3e39595ad0d51dbfbe68bd3f2c95b7af3d
parentRevert "Install /usr/lib/portage/bin compatibility symlink." (diff)
downloadmgorny-9907fe41a2bc6fc8dbe825d226bccf714dd17b24.tar.gz
mgorny-9907fe41a2bc6fc8dbe825d226bccf714dd17b24.tar.bz2
mgorny-9907fe41a2bc6fc8dbe825d226bccf714dd17b24.zip
sys-apps/portage: Use new distutils-r1 features to install docs without reinstalling whole Portage.
Package-Manager: portage-2.2.11_p165
-rw-r--r--sys-apps/portage/portage-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index b4e63e7..c949ece 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -186,8 +186,10 @@ python_install_all() {
use doc && targets+=( install_docbook )
use epydoc && targets+=( install_epydoc )
- # install docs + replace scripts with preferred impl
- python_install "${targets[@]}"
+ # install docs
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
}
pkg_preinst() {