summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-09 06:09:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-09 06:09:41 +0100
commit066c7193da221fa0292e917132585fad394259c2 (patch)
tree2d1ad7d5b48595482ceab3c4484b2a14a0194b7b
parentdev-python/botocore: Bump to 1.33.11 (diff)
downloadgentoo-066c7193da221fa0292e917132585fad394259c2.tar.gz
gentoo-066c7193da221fa0292e917132585fad394259c2.tar.bz2
gentoo-066c7193da221fa0292e917132585fad394259c2.zip
dev-python/boto3: Bump to 1.33.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.33.11.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 7f03cc202f49..eee1c40f1d73 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,6 +1,7 @@
DIST boto3-1.29.3.gh.tar.gz 737012 BLAKE2B 4282de0bbe03b61cf6884b08cf0a16e93c1e27a0323d2eee93277f8ac62f5ef440612292ebc245f13de0bbac9c156cae0cd5c76e8ae5b7d018a125cd49a682df SHA512 e42064e2c825376dfe2a5aa0c92715d06d6d29c3cf8b194d8742c688a4743e216ba32111bba080d88505907e48ff26086106eaef62fa5048f34fcbf08355ab60
DIST boto3-1.29.6.gh.tar.gz 738684 BLAKE2B a42245ddc7a0f31329057016f47739fc4071a030dca1ced347b447860e9397e3c8bae8c70ca86629a4b6b3f403ed845887340e6aeb08fe33c006dea9cd3f6317 SHA512 551a3568f3ceb1f37c7d209e7aa011dbd87d01e02f7559f15563bbd06da6d7a1ff79a1a5ed8150cfbc183cd1c56041a1e36753939142962f056348362665c118
DIST boto3-1.33.10.gh.tar.gz 753779 BLAKE2B 8c46c6459574307c9ed4700afd1dd3e67e308f5c911422fe8942cd2b6cf7cc20a067f52e6aaa65748c4edaaf73d9fe8904da2f5523c067dbb4676b4c13a9613c SHA512 9c8e75464754741732c1865c00f8d74bb50a0e1edd0c90645c92230e21ea28f55c3eff1fa7a80e616999fd0b063fd287d36838a12a828bcc6e6bd0a77205393d
+DIST boto3-1.33.11.gh.tar.gz 754430 BLAKE2B f206c6eeb9859af85f09bb48298b941fc0c969446766638c612fa1e88e19b8f9a99ec2ecbb8565a40432cc7a7f5362459af7488a172f4bca3179385d82742feb SHA512 03f37d99b70d857d2d72e81e02fe3afb64d3139adde80db0bf3a2f78ce8fa33c5cc6965a8dbfd267b263711c73c355d69d7e629eb7f28e6bdccf5480ca9c9810
DIST boto3-1.33.6.gh.tar.gz 752467 BLAKE2B f0f344a9e93ff3ad1dd03b44784a41637d05961855e2cd0700dbb840f98940f387cf81d1eb36cc63579be810f5a7d52c49cdb3831e930f89b1b2026af1e4b357 SHA512 1d3d2dd734621cf94e88015273f6fd4d68ec956145eb2b91fe34920f9abe7786a64e2e7f4057db30e71574e392fff9190944c3d9e6143fd43c5e48f04e9eb2ae
DIST boto3-1.33.7.gh.tar.gz 752960 BLAKE2B 2da4ddbf62008e7fe1b2f49eb1358e417ac3fb9ad80ccc18ad5be85b747f96060679a6bf466d970e62fa0bc3c3c91bab6516e8de5b14c6cca79e35be34ddf0d2 SHA512 5102d564cd749684ccab50a5de1782f07dbe1a5bb037f6f037e44e9fb8c1800f996faca855457976a65c49a38b9472d16ea288f140d946e50057a18a0c179b78
DIST boto3-1.33.8.gh.tar.gz 753219 BLAKE2B 8b6bc4c1d7e5a70f8061a7a966b3b9504e1c6cca604c7f7597ce7a1a05e213b903501c22d1d101fd814055cb112b7f690699ac714238743a64010d88724a3086 SHA512 7bbca4cee2610a5db246e9496bcb936b3266cb05b5aa8c919a06d824980bfbd7b974f9621bf13ce3efb78471b05968909558d94d941bd8764c1b67da25229e08
diff --git a/dev-python/boto3/boto3-1.33.11.ebuild b/dev-python/boto3/boto3-1.33.11.ebuild
new file mode 100644
index 000000000000..8123b4a12a79
--- /dev/null
+++ b/dev-python/boto3/boto3-1.33.11.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}