summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-26 03:25:03 +0000
committerSam James <sam@gentoo.org>2022-12-26 03:25:03 +0000
commit3ee2bffbe5df5f7d81cdbe1272beb3fc822e50c4 (patch)
tree707c306b817921cc4364410b3b104d05aacb76e5
parentsys-devel/gcc: add 13.0.0_pre20221225 (diff)
downloadgentoo-3ee2bffbe5df5f7d81cdbe1272beb3fc822e50c4.tar.gz
gentoo-3ee2bffbe5df5f7d81cdbe1272beb3fc822e50c4.tar.bz2
gentoo-3ee2bffbe5df5f7d81cdbe1272beb3fc822e50c4.zip
sys-devel/gcc: drop 10.4.1_p20221215
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/gcc/Manifest1
-rw-r--r--sys-devel/gcc/gcc-10.4.1_p20221215.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/sys-devel/gcc/Manifest b/sys-devel/gcc/Manifest
index e42a3be7fc2d..b3d6ea4269be 100644
--- a/sys-devel/gcc/Manifest
+++ b/sys-devel/gcc/Manifest
@@ -1,5 +1,4 @@
DIST gcc-10-20221208.tar.xz 72098912 BLAKE2B 8167b3d91fb95c727caa3a76d8bd6d70e0d0bd79eda72305f3005c9f7163dcd425c75386ba55b2d71644ecf83d998a4bccb6fd265bb615dcdd104f27cadb8e76 SHA512 5e49159d86300eaa4c2f34fb3537b5f257931e861a1a1217dbabcfcd5ef9da224d4a6023aaf8d24c8893ecd204ec0cd6e96349ae0dd445d62d92ebb041aeb054
-DIST gcc-10-20221215.tar.xz 72113292 BLAKE2B 141c2fa7fee0e6a461ca6008705b031b4fdce9a39340751bfca9045c70adbfda6f9ea2d792c688223fd25340df028a6d5d6347d6629d798179bfed7b0fac5736 SHA512 21796821a2fc4c5b46be29deb010db69380265a9732efe3e05a714929c4363a2e9b92556a666fee37b85bdc7069fb4bba9d7de4c5750fb327916627d6e9ad998
DIST gcc-10-20221222.tar.xz 72112292 BLAKE2B fad78a6bc00e23909fa4c441592e61311709efa770ec713c44923f6f088c1185c52022cb9fa2e13185e644b655b16f7b4f4247e93bc82925ae44b2580feab8dd SHA512 34ecb5def4152e69c6b2a5fcd111c244447f6c53ed4359516923331af4634e67b803635ec770f24fc7dc12a571918d523fdf4f23d13e7aec927a05f8c5b83090
DIST gcc-10.4.0-musl-patches-1.tar.xz 3808 BLAKE2B 804d1fcc451dcd03be71240dd498ec2d179869571d44012967c48dccf5a478dd8c55000a964a80fdd5584d739a777dee1c83241cffce514ef002df2572854a67 SHA512 83e4a9c0f7062baf0c606a2bcc56a818494991403d7577dea65f04bbc25bdb786a5889b80d45d80e7f4be07c1aef786802cbfcfafd1a17ec255a2d4e93a77570
DIST gcc-10.4.0-patches-5.tar.xz 17056 BLAKE2B f336d69a8ad105b8c4a84e8248a5b8a88175d3f1d67d32c6bee1780d252d86947059bd624992e6292610e86c9012f4d901a1a54df0d184dd023d404a0707700e SHA512 aa8fb42f20587f8519e7b06037da4d8f7d386b63e228b239a0445a51df4e401940fcd81482381d966622054aef3e0db06d1def5c74ac3d3dcc9c75c3b966c758
diff --git a/sys-devel/gcc/gcc-10.4.1_p20221215.ebuild b/sys-devel/gcc/gcc-10.4.1_p20221215.ebuild
deleted file mode 100644
index 8dae3d80c082..000000000000
--- a/sys-devel/gcc/gcc-10.4.1_p20221215.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-TOOLCHAIN_PATCH_SUFFIX="xz"
-TOOLCHAIN_PATCH_DEV="sam"
-#TOOLCHAIN_GCC_RC=1
-PATCH_GCC_VER="10.5.0"
-PATCH_VER="3"
-MUSL_VER="1"
-MUSL_GCC_VER="10.5.0"
-
-if [[ $(ver_cut 3) == 9999 ]] ; then
- MY_PV_2=$(ver_cut 2)
- if [[ ${MY_PV_2} == 0 ]] ; then
- MY_PV_2=0
- else
- MY_PV_2=$(($(ver_cut 2) - 1))
- fi
-
- # e.g. 12.2.9999 -> 12.1.1
- TOOLCHAIN_GCC_PV=$(ver_cut 1).${MY_PV_2}.$(($(ver_cut 3) - 9998))
-elif [[ -n ${TOOLCHAIN_GCC_RC} ]] ; then
- # Cheesy hack for RCs
- MY_PV=$(ver_cut 1).$((($(ver_cut 2) + 1))).$((($(ver_cut 3) - 1)))-RC-$(ver_cut 5)
- MY_P=${PN}-${MY_PV}
- GCC_TARBALL_SRC_URI="https://gcc.gnu.org/pub/gcc/snapshots/${MY_PV}/${MY_P}.tar.xz"
- TOOLCHAIN_SET_S=no
- S="${WORKDIR}"/${MY_P}
-fi
-
-inherit toolchain
-# Needs to be after inherit (for now?), bug #830908
-EGIT_BRANCH=releases/gcc-$(ver_cut 1)
-
-# Don't keyword live ebuilds
-#if ! tc_is_live && [[ -z ${TOOLCHAIN_USE_GIT_PATCHES} ]] ; then
-# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-#fi
-
-RDEPEND=""
-BDEPEND="${CATEGORY}/binutils"
-
-src_prepare() {
- local p upstreamed_patches=(
- # add them here
- )
- for p in "${upstreamed_patches[@]}"; do
- rm -v "${WORKDIR}/patch/${p}" || die
- done
-
- if has_version '>=sys-libs/glibc-2.32-r1'; then
- rm -v "${WORKDIR}/patch/23_all_disable-riscv32-ABIs.patch" || die
- fi
-
- toolchain_src_prepare
-}