summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-08-06 20:34:14 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-08-06 20:34:59 +0200
commit4162fc6d161a91049f28a9ab84f5d9f2ba79cd15 (patch)
tree05645a6fcb3373a8278017d10ae81024b3d40ab1
parentdev-libs/libmaxminddb: Version 1.4.3 (diff)
downloadgentoo-4162fc6d161a91049f28a9ab84f5d9f2ba79cd15.tar.gz
gentoo-4162fc6d161a91049f28a9ab84f5d9f2ba79cd15.tar.bz2
gentoo-4162fc6d161a91049f28a9ab84f5d9f2ba79cd15.zip
net-libs/ntirpc:
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-libs/ntirpc/Manifest2
-rw-r--r--net-libs/ntirpc/ntirpc-1.8.1.ebuild29
-rw-r--r--net-libs/ntirpc/ntirpc-3.3.ebuild33
3 files changed, 64 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index cbc524bd2ecb..da183c320571 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1,4 +1,6 @@
DIST ntirpc-1.7.1.tar.gz 373327 BLAKE2B 55d71932e35b844e382409593b5dead30246d0cbaa27d3d49ad94d09435acb8abb34b945ba90ab7ba9733a955b4184ad839ba202aa82f97eeecbcc502cb88bf0 SHA512 9a98d83db94b4775940584cd08a1105b79263412d44309f91d1e86c609e6d56a482ac239efaaa73ccc1c2f4cabb8b597ccb8931514f33b8b2fd5c2a11b731106
DIST ntirpc-1.7.4.tar.gz 373897 BLAKE2B 7354c5d6114947c8d66dcbc4fb933ab38237dd70eeb318278a658946fa4ec354bcaf7e90ac210f39f76b6d8e60f865c0c63ecbf7cbd8ee1e8defa0d7622cfb51 SHA512 076d789edc3fdf0ddb75437196b72b1aef78780d579ae4db0bcc116a1a92ac861fc77e1611070f2d3df003bfec7883ab20653a3c2f2255c685aaed8e7c22ce0f
+DIST ntirpc-1.8.1.tar.gz 375019 BLAKE2B 3c774dbb762759f920e4159aaf5e4942c13837413bf72ab17298298a15278bc92332f8835701e0895f252596c21ba0d750c5f7f8afcf9104b8118745208fb1ec SHA512 a20749afb6d1f6216d6f5b6c9c29f6d988064d9cda8d3bfd855e62ba0ef88c7b47026d79c77be815c21eb91af0fcc6566af85df2401b5cef20c7ddfa5c5525b1
DIST ntirpc-3.0.tar.gz 386738 BLAKE2B 123c8f31ea532f6a01b4544d4f19d503c6e44ec8f3923f3f053f1ccc2ff5c5dc62da6464373b25a1881f69749a4c62395838be4451f3281ed9e7446eb8380255 SHA512 a7e9fdfcdaa2e85d4631094874bd72dce6c2e93924f6099f6bc20c98a1792839559ffb028b100aa3c5ec0140c10e090b32155439846276f918e9ba017271e14b
DIST ntirpc-3.2.tar.gz 386961 BLAKE2B 920917b7ec08e2d4147785e1753596f035de684ffd92fb55fdf553bb4e19160e40fb829bd867d5a3a43f36568f731f71c31f135b6fe07fea2a6088f27ee3c6ff SHA512 8e9b5b3e607e28c4033c5986dbbc248d0edfeda6138b3ff51cc0760dccfb1cf4a14ff6bbec4330421b1175c3b1b04a34a43f314c97be2758fe0331b775f86021
+DIST ntirpc-3.3.tar.gz 387212 BLAKE2B ee656510cadaa041b4ea389710f667021e07697744dd60ce71f4e856ed91339cc5373bba771ba6bcc09d86e32502339bce7fb1c7e8ae411ec38ebade87cdb735 SHA512 c5586be51960c682f719dc0aae21846cb1af6bab10c1d3b946570508947d281f776595e2f0d12edddd9d0289e737fc2fb823ed5060dba6b6e5c6b01f28c84cde
diff --git a/net-libs/ntirpc/ntirpc-1.8.1.ebuild b/net-libs/ntirpc/ntirpc-1.8.1.ebuild
new file mode 100644
index 000000000000..931e0dca527e
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-1.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="dev-libs/userspace-rcu
+ rdma? ( sys-fabric/librdmacm )"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-libs/ntirpc/ntirpc-3.3.ebuild b/net-libs/ntirpc/ntirpc-3.3.ebuild
new file mode 100644
index 000000000000..16b76a069fd1
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-3.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu
+ rdma? ( sys-fabric/librdmacm )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}