summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-20 22:44:46 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-20 22:45:10 +0100
commit4a95491d669ef0a95bc8a8c705aea5149e2f0148 (patch)
treed77e885d930f95163e69826b8c3b876838c06e78
parentapp-admin/ranpwd: Keyword 1.2 riscv, #944051 (diff)
downloadgentoo-4a95491d669ef0a95bc8a8c705aea5149e2f0148.tar.gz
gentoo-4a95491d669ef0a95bc8a8c705aea5149e2f0148.tar.bz2
gentoo-4a95491d669ef0a95bc8a8c705aea5149e2f0148.zip
sci-mathematics/why3: Fix sa_handler signature
Closes: https://bugs.gentoo.org/944186 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--sci-mathematics/why3/files/why3-1.7.2-signum.patch11
-rw-r--r--sci-mathematics/why3/why3-1.7.2.ebuild2
2 files changed, 13 insertions, 0 deletions
diff --git a/sci-mathematics/why3/files/why3-1.7.2-signum.patch b/sci-mathematics/why3/files/why3-1.7.2-signum.patch
new file mode 100644
index 000000000000..97c014df8b91
--- /dev/null
+++ b/sci-mathematics/why3/files/why3-1.7.2-signum.patch
@@ -0,0 +1,11 @@
+--- a/src/server/cpulimit-unix.c 2024-11-20 22:37:00.519645455 +0100
++++ b/src/server/cpulimit-unix.c 2024-11-20 22:39:55.096447774 +0100
+@@ -42,7 +42,7 @@
+ }
+ }
+
+-void wallclock_timelimit_reached() {
++void wallclock_timelimit_reached(__attribute__((unused)) int signum) {
+ fprintf(stderr,
+ "Why3cpulimit: wallclock timelimit %d reached, killing command\n",
+ wallclock_timelimit);
diff --git a/sci-mathematics/why3/why3-1.7.2.ebuild b/sci-mathematics/why3/why3-1.7.2.ebuild
index 7517d54b1b67..888c5c48f865 100644
--- a/sci-mathematics/why3/why3-1.7.2.ebuild
+++ b/sci-mathematics/why3/why3-1.7.2.ebuild
@@ -46,6 +46,8 @@ BDEPEND="
DOCS=( CHANGES.md README.md )
+PATCHES=( "${FILESDIR}"/${P}-signum.patch )
+
src_prepare() {
mv configure.in configure.ac || die