summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-21 05:51:26 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-21 05:51:26 +0100
commit503db932f006e3051148c4ba0df7d143c8a80bff (patch)
tree2d59f3b4be3df18c2649fd713176f9a032328560
parentwww-client/chromium: add 132.0.6834.15 (diff)
downloadgentoo-503db932f006e3051148c4ba0df7d143c8a80bff.tar.gz
gentoo-503db932f006e3051148c4ba0df7d143c8a80bff.tar.bz2
gentoo-503db932f006e3051148c4ba0df7d143c8a80bff.zip
dev-python/botocore: Bump to 1.35.66
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.66.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d08176d310f6..922e45fbc7d7 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.35.57.gh.tar.gz 13603794 BLAKE2B 23a4dc82e1d9667e75494c2fb651b88
DIST botocore-1.35.63.gh.tar.gz 13692343 BLAKE2B 41ded808c412e9af8f938cf64db1632478f77d082417afac1f34905e946c0459545afa46854a41458090eab26a32b2733fb164f374455d8bdefea35718182632 SHA512 7185f5a288f848e1f3810ab9fa4eb46467321af6bdd345a8de623722ee513ab89f43303955487b014a3c349ed69a62c7bdf54e5095c3f4ebfd254fab51443ca8
DIST botocore-1.35.64.gh.tar.gz 13718535 BLAKE2B 6fb1e8f858b9b5ea0796df76bed1df5b66dcce9eedd7e82c736def7b8f515354e157f1892f2a8b0c7d26cc4cc0501c122c0c8002c4dec0e175adf5c37e26a861 SHA512 d822ed760c0abf04afd2929a634fed9bb52ab9829a16cf31777fc832c7ec58594fbdd17e66f113332d1c63f9beb3310565aabece069941750fa1a172fdbf9163
DIST botocore-1.35.65.gh.tar.gz 13727546 BLAKE2B a910934f226ca55c2cc55763f7a3eebdfe299410b9a99aadab3d938b864056063649984527f161969a3b0840bfad1e0bab07042c49de1efc8d25a3e17d33c496 SHA512 d7116f80522c3f5bafb29b7688800752539ee2ff06e53fd6b2a9c9cf3f37f9dcb3a731ec08d2cf735f737cabff3f5aa8314df697748135c56902c0ff4a3040ec
+DIST botocore-1.35.66.gh.tar.gz 13752979 BLAKE2B cd8732c85c471c8360e6680e574a098e039020a22e4634f8c1f00df104e80b462f80be88db5b8f58e4d230acee8334ac8a5730fa63b8ced1f26e30922596f7d5 SHA512 29cd9ddbe8e51c5610ff1616c772da362721960eef72e95bf16559f175fa4ab908d54bf095154c6743f0fdcb057c966352beea693cc10b00ec7bf590da3e7e50
diff --git a/dev-python/botocore/botocore-1.35.66.ebuild b/dev-python/botocore/botocore-1.35.66.ebuild
new file mode 100644
index 000000000000..0f88c5cbe9f3
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.66.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}