summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-20 11:49:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-20 11:49:22 +0200
commit67c482fb5d43d5d2c063d8d0a7b9f5129a778713 (patch)
tree05a87ca5a603d3d3590b121a2c251b7089a9b5d1
parentdev-python/path: Stabilize 16.12.1 ALLARCHES, #930319 (diff)
downloadgentoo-67c482fb5d43d5d2c063d8d0a7b9f5129a778713.tar.gz
gentoo-67c482fb5d43d5d2c063d8d0a7b9f5129a778713.tar.bz2
gentoo-67c482fb5d43d5d2c063d8d0a7b9f5129a778713.zip
dev-python/quart: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/quart/Manifest1
-rw-r--r--dev-python/quart/quart-0.19.4.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/quart/Manifest b/dev-python/quart/Manifest
index 0fbb8ac1aff4..277cc969ecb4 100644
--- a/dev-python/quart/Manifest
+++ b/dev-python/quart/Manifest
@@ -1,2 +1 @@
-DIST quart-0.19.4.gh.tar.gz 493787 BLAKE2B 8a754687cc2e8321ed6b2243cfe519d95e955869a1a12c89a22aa3e304466a4a496531e7ca8e819c0daee88a6b077e7b54dbef02de84abd6f6dbf7b8988e139f SHA512 d6673a43733b8f1caa2180c545cea99eb9670d802b29f123e6c499345bc33cc5f36c9146757e0eea9def811043a9b0e7d59e5e7012ee965b425ec32620cd383a
DIST quart-0.19.5.gh.tar.gz 494282 BLAKE2B d908638a00d67798dc71bb84ab51b2b35ee55c1b16ba88781642a1b64b70e0206e33c4e61cb397451969d0edde593ac2639ce8000838750e312b1ef47b8b154a SHA512 a764f50b19c84f7b4cf368488a703c726b2e98785cc7e0c15de0c3293f764658bb6e1489be53bb03ca135ccd847383424fdba8706383a45f406c39fdceb26d71
diff --git a/dev-python/quart/quart-0.19.4.ebuild b/dev-python/quart/quart-0.19.4.ebuild
deleted file mode 100644
index 8f88cb4d2002..000000000000
--- a/dev-python/quart/quart-0.19.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python ASGI web microframework with the same API as Flask"
-HOMEPAGE="
- https://github.com/pallets/quart/
- https://pypi.org/project/Quart/
-"
-# no tests in sdist as of 0.19.4
-SRC_URI="
- https://github.com/pallets/quart/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/aiofiles[${PYTHON_USEDEP}]
- >=dev-python/blinker-1.6[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/hypercorn-0.11.2[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-3.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -p asyncio
-}