summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-17 21:45:35 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-17 21:46:07 +0200
commit9182f48a8369cc7b95a994d8c31549ebad4bfa1b (patch)
tree92a2e3879d824b5c95697ff67994fad1ad7de31a
parentmedia-gfx/scrot: Stabilize 1.10 arm, #920218 (diff)
downloadgentoo-9182f48a8369cc7b95a994d8c31549ebad4bfa1b.tar.gz
gentoo-9182f48a8369cc7b95a994d8c31549ebad4bfa1b.tar.bz2
gentoo-9182f48a8369cc7b95a994d8c31549ebad4bfa1b.zip
dev-util/codespell: add 2.2.6
Closes: https://bugs.gentoo.org/911240 Closes: https://bugs.gentoo.org/919800 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-util/codespell/Manifest1
-rw-r--r--dev-util/codespell/codespell-2.2.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/codespell/Manifest b/dev-util/codespell/Manifest
index a7e8b39bac0f..2e077fb9b013 100644
--- a/dev-util/codespell/Manifest
+++ b/dev-util/codespell/Manifest
@@ -1,2 +1,3 @@
DIST codespell-2.2.4.tar.gz 241664 BLAKE2B 5f40003fdb840b926615b6eed74df90055b2ee47c534321289c3ed895c47cd2672909b152a53640899cc21960c1b3aa80c41eb344d9e23cea8fd13e998c71af6 SHA512 efbc62a3dd49781565f6d901aa9b08fc1106adf2c516365dd8d3684846e23b23bfda1e65c6530edf0de9462ccafd9d835bd541a8f0e1de14163c723ce041052d
DIST codespell-2.2.5.tar.gz 242918 BLAKE2B 18b4ff620edb54950ba2779ec610f15597d0aef5e4dded3ed2055ce7769e16d70dbac9cf990b2bdb6c216f8f6204e4a7790fe011ec53057553ca6981b4d8c851 SHA512 173eb13695ceccb4bb081907fc8d703e91922ec7adddc150aa2db1629353edff464c2318f2abaf78e8c96ab28f08e510897912f5bd48d69a6c50e025d470b53f
+DIST codespell-2.2.6.tar.gz 300968 BLAKE2B f97aca1c1398cecd6257dc5fc8c0c6e8b35d34a82338e0ede4b03b6df8d030f095fbb8ae77a5bcfe6955f954a556fcea34927b4f44069010becd724b29a07184 SHA512 993734138e017324039a2954fc3559411aa7e3a96b8e6b6b2176985641225755adb9dde7125260211e531a1ecf1f1d82f2294434c21e8a35c7898212f3db3273
diff --git a/dev-util/codespell/codespell-2.2.6.ebuild b/dev-util/codespell/codespell-2.2.6.ebuild
new file mode 100644
index 000000000000..823a11f1e0b6
--- /dev/null
+++ b/dev-util/codespell/codespell-2.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Check text files for common misspellings"
+HOMEPAGE="https://pypi.org/project/codespell
+ https://github.com/codespell-project/codespell"
+
+# Code licensed under GPL-2, dictionary licensed under CC-BY-SA-3.0
+LICENSE="GPL-2 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Remove bundled dictionary
+ sed -e '/addopts/d' -i pyproject.toml || die
+}