summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-09-24 14:54:26 +1000
committerMatt Jolly <kangie@gentoo.org>2024-09-24 16:30:36 +1000
commit92ad3787af656bf88a15ecf9044393d63491a552 (patch)
tree686ec019d33570f5a2a821b4b964735cfc513297
parentapp-misc/elasticsearch: drop 8.14.3 (diff)
downloadgentoo-92ad3787af656bf88a15ecf9044393d63491a552.tar.gz
gentoo-92ad3787af656bf88a15ecf9044393d63491a552.tar.bz2
gentoo-92ad3787af656bf88a15ecf9044393d63491a552.zip
games-fps/alephone: add 20240822; update live
- major upstream build system changes and simplifications. Signed-off-by: Matt Jolly <kangie@gentoo.org>
-rw-r--r--games-fps/alephone/Manifest1
-rw-r--r--games-fps/alephone/alephone-20240822.ebuild92
-rw-r--r--games-fps/alephone/alephone-99999999.ebuild43
-rw-r--r--games-fps/alephone/files/alephone-20230119-c99.patch99
4 files changed, 108 insertions, 127 deletions
diff --git a/games-fps/alephone/Manifest b/games-fps/alephone/Manifest
index 24554b54aee2..3455461e77e5 100644
--- a/games-fps/alephone/Manifest
+++ b/games-fps/alephone/Manifest
@@ -1 +1,2 @@
+DIST alephone-20240822.tar.gz 9146694 BLAKE2B 236997765085c520b90399cffba04a5edeb54810e1d0b614ded183addf7520727b6750971cdc70215e211547514209b01c7e515c4e1e7296e18c99c1a79ff958 SHA512 e00dbc4cb84c40c666554114c47f3eff59ab6fbc101d45d20ae510d9cc2ef1d75300f2554f61396939d030d1fd5ff237b512c6e34ae779523b93e206368bec3d
DIST release-20230119.tar.gz 6968352 BLAKE2B 06bc87b4c2bc6a311ee90f854f7c35fb4da2862c417b192a4364dbd38cac9c0c02c4439abf07e6bc7c2d68899fae4dd938464896039943f1fa6ae5a4a644260f SHA512 d1ede53c20a24b74f5525e2e8c09fdbbb05fa0262bbd8f6c1abe6c3698cdfd1dea2436487ec8f64c79a7e1f150367e40ea48838f8a42031b45c0b1498a0e77d1
diff --git a/games-fps/alephone/alephone-20240822.ebuild b/games-fps/alephone/alephone-20240822.ebuild
new file mode 100644
index 000000000000..7219486b5808
--- /dev/null
+++ b/games-fps/alephone/alephone-20240822.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic optfeature prefix toolchain-funcs xdg
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="https://alephone.lhowon.org/"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Aleph-One-Marathon/alephone/"
+ EGIT_SUBMODULES=() # Upstream includes game data as submodules, we only want the engine
+else
+ SRC_URI="https://github.com/Aleph-One-Marathon/alephone/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-release-${PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+ BitstreamVera OFL-1.1"
+SLOT="0"
+
+IUSE="curl upnp"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/zziplib:=
+ media-libs/openal
+ media-libs/libpng
+ media-libs/libsdl2
+ media-libs/libsndfile
+ media-libs/sdl2-image[png]
+ media-libs/sdl2-net
+ media-libs/sdl2-ttf
+ media-video/ffmpeg:=[mp3,vorbis]
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu
+ curl? ( net-misc/curl )
+ upnp? ( net-libs/miniupnpc )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # With LTO enabled enemies are not visible
+ # https://github.com/Aleph-One-Marathon/alephone/issues/518
+ filter-lto
+ my_econf=(
+ --enable-opengl
+ --with-ffmpeg
+ --with-png
+ --with-sdl_image
+ --with-zzip
+ $(use_with curl)
+ $(use_with upnp miniupnpc)
+ )
+ econf "${my_econf[@]}"
+}
+
+src_compile() {
+ tc-export AR
+ default
+}
+
+src_install() {
+ default
+ prefixify_ro "${FILESDIR}"/${PN}.sh
+ dobin "${T}"/${PN}.sh
+ doman docs/${PN}.6
+ docinto html/
+ dodoc docs/*.html
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature_header "Install game data:"
+ optfeature "Marathon data files" games-fps/alephone-marathon
+ optfeature "Marathon 2 Durandal data files" games-fps/alephone-durandal
+ optfeature "Marathon: Infinity data files" games-fps/alephone-infinity
+}
diff --git a/games-fps/alephone/alephone-99999999.ebuild b/games-fps/alephone/alephone-99999999.ebuild
index 9a32dc2729ec..7219486b5808 100644
--- a/games-fps/alephone/alephone-99999999.ebuild
+++ b/games-fps/alephone/alephone-99999999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/Aleph-One-Marathon/alephone/"
EGIT_SUBMODULES=() # Upstream includes game data as submodules, we only want the engine
else
- SRC_URI="https://github.com/Aleph-One-Marathon/alephone/archive/refs/tags/release-${PV}.tar.gz"
+ SRC_URI="https://github.com/Aleph-One-Marathon/alephone/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-release-${PV}"
KEYWORDS="~amd64"
fi
@@ -20,19 +20,15 @@ fi
LICENSE="GPL-3+ BitstreamVera OFL-1.1"
SLOT="0"
-IUSE="alsa curl speex upnp"
+IUSE="curl upnp"
-# ffmpeg covers most audio/video use cases and the package doesn't configure
-# with alternatives enabled (media-libs/smpeg)
-# When resolved upstream,
-# !ffmpeg ( media-libs/libmad media-libs/libsndfile media-libs/libvorbis media-libs/smpeg )
-# with an appropriate REQUIRED_USE may be added.
-# See https://github.com/Aleph-One-Marathon/alephone/issues/85
RDEPEND="
dev-libs/boost:=
dev-libs/zziplib:=
+ media-libs/openal
media-libs/libpng
media-libs/libsdl2
+ media-libs/libsndfile
media-libs/sdl2-image[png]
media-libs/sdl2-net
media-libs/sdl2-ttf
@@ -40,12 +36,7 @@ RDEPEND="
sys-libs/zlib
virtual/opengl
virtual/glu
- alsa? ( media-libs/alsa-lib )
curl? ( net-misc/curl )
- speex? (
- media-libs/speex
- media-libs/speexdsp
- )
upnp? ( net-libs/miniupnpc )
"
@@ -63,23 +54,19 @@ src_prepare() {
}
src_configure() {
- # -Werror=odr
- # https://bugs.gentoo.org/873298
- # https://github.com/Aleph-One-Marathon/alephone/issues/475
+ # With LTO enabled enemies are not visible
+ # https://github.com/Aleph-One-Marathon/alephone/issues/518
filter-lto
-
- econf \
- --enable-lua \
- --enable-opengl \
- --with-ffmpeg \
- --without-mad \
- --without-smpeg \
- --without-sndfile \
- --without-vorbis \
- $(use_with alsa) \
- $(use_with curl) \
- $(use_with speex) \
+ my_econf=(
+ --enable-opengl
+ --with-ffmpeg
+ --with-png
+ --with-sdl_image
+ --with-zzip
+ $(use_with curl)
$(use_with upnp miniupnpc)
+ )
+ econf "${my_econf[@]}"
}
src_compile() {
diff --git a/games-fps/alephone/files/alephone-20230119-c99.patch b/games-fps/alephone/files/alephone-20230119-c99.patch
deleted file mode 100644
index 7340e1fb2be0..000000000000
--- a/games-fps/alephone/files/alephone-20230119-c99.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-https://github.com/Aleph-One-Marathon/alephone/pull/405
-From: Matt Jolly <Matt.Jolly@footclan.ninja>
-Date: Sat, 28 Jan 2023 18:03:51 +1100
-Subject: [PATCH] use designated initialisers for SDL_ffmpegCodec*
-
-These were failing to compile under clang16 as the old `audioBitrate`
-was being jammed into `crf`, causing an incompatible integer conversion.
---- a/Source_Files/FFmpeg/SDL_ffmpeg.c
-+++ b/Source_Files/FFmpeg/SDL_ffmpeg.c
-@@ -155,41 +155,55 @@ int SDL_ffmpegDecodeVideoFrame( SDL_ffmpegFile*, AVPacket*, SDL_ffmpegVideoFrame
-
- const SDL_ffmpegCodec SDL_ffmpegCodecAUTO =
- {
-- -1,
-- 720, 576,
-- 1, 25,
-- 6000000,
-- -1, -1,
-- -1,
-- 2, 48000,
-- 192000,
-- -1, -1
-+ .videoCodecID=-1,
-+ .width=720,
-+ .height=576,
-+ .framerateNum=1,
-+ .framerateDen=25,
-+ .videoBitrate=6000000,
-+ .videoMinRate=-1,
-+ .videoMaxRate=-1,
-+ .audioCodecID=-1,
-+ .channels=2,
-+ .sampleRate=48000,
-+ .cpuCount=-1,
-+ .audioQuality=-1
- };
-
-+
-+
- const SDL_ffmpegCodec SDL_ffmpegCodecPALDVD =
- {
-- AV_CODEC_ID_MPEG2VIDEO,
-- 720, 576,
-- 1, 25,
-- 6000000,
-- -1, -1,
-- AV_CODEC_ID_MP2,
-- 2, 48000,
-- 192000,
-- -1, -1
-+ .videoCodecID=AV_CODEC_ID_MPEG2VIDEO,
-+ .width=720,
-+ .height=576,
-+ .framerateNum=1,
-+ .framerateDen=25,
-+ .videoBitrate=6000000,
-+ .videoMinRate=-1,
-+ .videoMaxRate=-1,
-+ .audioCodecID=AV_CODEC_ID_MP2,
-+ .channels=2,
-+ .sampleRate=48000,
-+ .cpuCount=-1,
-+ .audioQuality=-1
- };
-
- const SDL_ffmpegCodec SDL_ffmpegCodecPALDV =
- {
-- AV_CODEC_ID_DVVIDEO,
-- 720, 576,
-- 1, 25,
-- 6553600,
-- -1, -1,
-- AV_CODEC_ID_DVAUDIO,
-- 2, 48000,
-- 256000,
-- -1, -1
-+ .videoCodecID=AV_CODEC_ID_DVVIDEO,
-+ .width=720,
-+ .height=576,
-+ .framerateNum=1,
-+ .framerateDen=25,
-+ .videoBitrate=6553600,
-+ .videoMinRate=-1,
-+ .videoMaxRate=-1,
-+ .audioCodecID=AV_CODEC_ID_DVAUDIO,
-+ .channels=2,
-+ .sampleRate=48000,
-+ .cpuCount=-1,
-+ .audioQuality=-1
- };
-
- SDL_ffmpegFile* SDL_ffmpegCreateFile()
-@@ -2269,4 +2283,4 @@ int SDL_ffmpegDecodeVideoFrame( SDL_ffmpegFile* file, AVPacket *pack, SDL_ffmpeg
- /**
- \endcond
- */
--#endif
-\ No newline at end of file
-+#endif