summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2020-11-07 11:39:21 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-07 20:31:29 -0500
commita8982511249953dbb4316e1dc4d30cf3f9d639db (patch)
treeba4dae5626d89207271a84e7e3864f87a5e3b321
parentx11-libs/libxshmfence: EAPI 7 (diff)
downloadgentoo-a8982511249953dbb4316e1dc4d30cf3f9d639db.tar.gz
gentoo-a8982511249953dbb4316e1dc4d30cf3f9d639db.tar.bz2
gentoo-a8982511249953dbb4316e1dc4d30cf3f9d639db.zip
x11-misc/notification-daemon: EAPI 7
Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild b/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild
new file mode 100644
index 000000000000..136f1965fa15
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org
+
+DESCRIPTION="Notification daemon"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/notification-daemon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.19.5:3[X]
+ sys-apps/dbus
+ x11-libs/libX11
+ !x11-misc/notify-osd
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ default
+
+ insinto /usr/share/dbus-1/services
+ newins <<-EOF - org.freedesktop.Notifications.service
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/notification-daemon
+ EOF
+}