summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-07-15 12:15:53 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-07-15 12:15:53 +0200
commita8a4476fc22eb0b1c702adf2b20c17f51f842ec2 (patch)
tree2f24c47971cf0059bbea608f647a81b543f62e1c
parentdev-ml/opam-repository: add 2.1.5 (diff)
downloadgentoo-a8a4476fc22eb0b1c702adf2b20c17f51f842ec2.tar.gz
gentoo-a8a4476fc22eb0b1c702adf2b20c17f51f842ec2.tar.bz2
gentoo-a8a4476fc22eb0b1c702adf2b20c17f51f842ec2.zip
dev-ml/opam-state: add 2.1.5
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/opam-state/Manifest1
-rw-r--r--dev-ml/opam-state/opam-state-2.1.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/opam-state/Manifest b/dev-ml/opam-state/Manifest
index 13cb1b80d395..d1d1ef4c062e 100644
--- a/dev-ml/opam-state/Manifest
+++ b/dev-ml/opam-state/Manifest
@@ -3,3 +3,4 @@ DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e5137
DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c679519895aa2568f0c2d199d4ba9d6ae948a4fc418cfd26cc65079eb6ef3545f24a35e08c969d215529664a80d0c9147 SHA512 e00da74d7baef62319e884e3a05112bcf86a02d887c274bd15fb0d15bb8198e9a37a421f388bec3fce198e7a1b4d37024b18609dc65978c6ee8a7889df9bd608
DIST opam-2.1.2.tar.gz 818848 BLAKE2B ffb50f3cf1421aa9bff6877d636a3d1d1cc2c2e3961ecd60fcae8a35b069c8d22e7a36bf17cb8166533621a3c85a82195fd3fa646b2fd8dcea9e626b61d5b86c SHA512 bea6f75728a6ef25bcae4f8903dde7a297df7186208dccacb3f58bd6a0caec551c11b79e8544f0983feac038971dbe49481fc405a5962973a5f56ec811abe396
DIST opam-2.1.3.tar.gz 832450 BLAKE2B c5e50c0a41b7197bc7645eaef0d8cba79c978b4432fc824aa6a4280df65ec7d59df52a22b76877da4949c8562a5fecb8da2a179ca67bd312bf9a514961bf4444 SHA512 040e4f58f93e962ff422617ce0d35ed45dd86921a9aac3505914c33dd942d0e5e5771e7e1774046504f9aa84f32bc4fbd6ac7720fbea862d48bf1ca29e02cefc
+DIST opam-2.1.5.tar.gz 837005 BLAKE2B f2e58784959f0e47fbe5ae65112a030d8350b061d7b0d2676f40e22ec5bf62c136bc37fd3078403dab807705ce8a1c8b6bb0ecf00b68fdfbb5f3d5a9acb88c77 SHA512 4395defe7df1d03ca889718b8eafd8161ff009710475f62673f19f012e0bde8ad2a919bd9d02d7f96b4c5a9bbf38e0ba9a256531c24de15cafabd4ef11f7c8e8
diff --git a/dev-ml/opam-state/opam-state-2.1.5.ebuild b/dev-ml/opam-state/opam-state-2.1.5.ebuild
new file mode 100644
index 000000000000..044d439cdd5d
--- /dev/null
+++ b/dev-ml/opam-state/opam-state-2.1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="opam state libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ ~dev-ml/opam-repository-${PV}:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}
+
+src_compile() {
+ dune-compile ${PN}
+}