summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-10 19:01:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-10 22:11:58 +0100
commitab94de30c1290ee6e9da12ea35f2fa0de4022baf (patch)
tree82395780fde3d7ca976e2fe71ca0478c3cb2b468
parentdev-python/pyrate-limiter: Bump to 3.2.0 (diff)
downloadgentoo-ab94de30c1290ee6e9da12ea35f2fa0de4022baf.tar.gz
gentoo-ab94de30c1290ee6e9da12ea35f2fa0de4022baf.tar.bz2
gentoo-ab94de30c1290ee6e9da12ea35f2fa0de4022baf.zip
dev-python/pytest-plus: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-plus/Manifest1
-rw-r--r--dev-python/pytest-plus/pytest-plus-0.6.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-plus/Manifest b/dev-python/pytest-plus/Manifest
index bfa91ba7b210..013589819c34 100644
--- a/dev-python/pytest-plus/Manifest
+++ b/dev-python/pytest-plus/Manifest
@@ -1 +1,2 @@
DIST pytest-plus-0.6.0.tar.gz 12795 BLAKE2B 6e618f29e679cf1c71018ab4993606add89a4e3fe47a78b3cb4a17908c2bb0192646108918786183b330016a8e8d5458e87900d8bf4b9b61e90d3e24feab43a8 SHA512 7798a4e53a4ca95b24f9039accea2657746982370cd99f5d34d5dceccc08640214241f1e81f3e354f03782f013bf1b375a4e16a69d23e211948232eca678f98d
+DIST pytest-plus-0.6.1.tar.gz 12811 BLAKE2B f3892227aa24466b2f2e35187bbf7cf3d67d96745377356b3cc4d295a9fdd8eab8b0fd11b7b5ba96d5209e2bd7440f5e12084cbd83951e3e56cb24c1f2bf6f7b SHA512 4ee2fa8783c36e65616b1fc2e155e4c4898e0a6347058619f9cc0caa319fc62b34304a2ec0377071abef7d2a526c81729f434b228f0fb2b9d1c73fae1169bfde
diff --git a/dev-python/pytest-plus/pytest-plus-0.6.1.ebuild b/dev-python/pytest-plus/pytest-plus-0.6.1.ebuild
new file mode 100644
index 000000000000..2e2fb20a9f8c
--- /dev/null
+++ b/dev-python/pytest-plus/pytest-plus-0.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyTest Plus Plugin - extends pytest functionality"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-plus/
+ https://pypi.org/project/pytest-plus/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest