summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-05-19 15:33:46 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-05-19 15:40:30 +0200
commitb4d0130547be55bf383e545baaba27c32f4d3d5d (patch)
tree552efc9e6f57902003c6bca3df05fc23e62f669b
parentdev-python/jupyterlab: add 4.0.0 (diff)
downloadgentoo-b4d0130547be55bf383e545baaba27c32f4d3d5d.tar.gz
gentoo-b4d0130547be55bf383e545baaba27c32f4d3d5d.tar.bz2
gentoo-b4d0130547be55bf383e545baaba27c32f4d3d5d.zip
dev-python/jupyterlab-lsp: add 4.1.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/jupyterlab-lsp/Manifest1
-rw-r--r--dev-python/jupyterlab-lsp/jupyterlab-lsp-4.1.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-lsp/Manifest b/dev-python/jupyterlab-lsp/Manifest
index 2825f1c72da1..4fd8844edd15 100644
--- a/dev-python/jupyterlab-lsp/Manifest
+++ b/dev-python/jupyterlab-lsp/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-lsp-4.0.1.tar.gz 869528 BLAKE2B 62df16ba8aef6c344324346501191776a0534ddf6b5acff4de477f8f7f8996f7ec78022bada4c16d582fdfb7f916fd70f6c9c176505d25c47e863aa65f681f77 SHA512 8f71a6f39bec08fab8401a7074d65fa9a4bdca66ed3c11f75777095f160e9eab25b75b21f1ea4e509f43ff0beebe777f690c13ad0325b5ee26bcd1ec301119e4
+DIST jupyterlab-lsp-4.1.0.tar.gz 870899 BLAKE2B df1df3fc4dfc6cf268d2a81dcc63683e9b31595d633929b7788da21cfbc20f3da4c202e0d8fdcca3cfe033ed953e661bbaad605b783db8d5a26adc5ae169f2e4 SHA512 1510db853b75aeccc8dfbb9f466214c447fbdc8f885027c99ee7527c7759afa9774cfa682f3f66c6cce37767339b6e54338a7a14f6dc1d30b9944e1d1de8ff3c
diff --git a/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.1.0.ebuild b/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.1.0.ebuild
new file mode 100644
index 000000000000..f8fbb2f8f9b2
--- /dev/null
+++ b/dev-python/jupyterlab-lsp/jupyterlab-lsp-4.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="Coding assistance for JupyterLab with Language Server Protocol"
+HOMEPAGE="https://github.com/jupyter-lsp/jupyterlab-lsp"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyterlab-3.6.0[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-lsp-2.0.0[${PYTHON_USEDEP}]
+"