summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-07-26 22:05:34 +0200
committerSebastian Pipping <sping@gentoo.org>2020-07-26 22:06:13 +0200
commitc4f5072a3e486ed5c529d5630e1fa0d4aef04903 (patch)
tree291bd6a9ca5d5361661629491a351d18eec40593
parentdev-libs/appstream: Drop 0.12.11 (r0) (diff)
downloadgentoo-c4f5072a3e486ed5c529d5630e1fa0d4aef04903.tar.gz
gentoo-c4f5072a3e486ed5c529d5630e1fa0d4aef04903.tar.bz2
gentoo-c4f5072a3e486ed5c529d5630e1fa0d4aef04903.zip
dev-python/python-dotenv: 0.14.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
-rw-r--r--dev-python/python-dotenv/Manifest1
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.14.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-dotenv/Manifest b/dev-python/python-dotenv/Manifest
index 476e0a9e39cd..1c7adbe211e7 100644
--- a/dev-python/python-dotenv/Manifest
+++ b/dev-python/python-dotenv/Manifest
@@ -1 +1,2 @@
DIST python-dotenv-0.13.0.tar.gz 28679 BLAKE2B 068c4cb499956a14bb4c310d2c9a63f4c33b6621efd11c231eeea2808951530fa6e7bd5356973c19f7ba6f3693434ca46bfadd065c7369f95014389badb2a00c SHA512 a7e725fd0fcb262f240a8f9eb6cf9b73560d799a10ec946cf901f960cbfa972396ead1aca833808a1675ebaec0b89720c32b2fe957ef9805faa942b0df1a9608
+DIST python-dotenv-0.14.0.tar.gz 29029 BLAKE2B 33db159192faf9b74439b5e98e2b9a090a68001ac19eafd2925071ac7fc1872f7ee585b575dd96615c2ef934041dbfacca7948b7a8a69419243f9823f3bf6b42 SHA512 e8f6d575cd76cb231d14d98befe8a75017c927e0de39fbffc0ecb852b2aab1ada964cf37ed51c50968a4e8a96822a794c960a058a6deb6a2f0a8f8061d0560df
diff --git a/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
new file mode 100644
index 000000000000..19b23974b9e8
--- /dev/null
+++ b/dev-python/python-dotenv/python-dotenv-0.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Manage .env files"
+HOMEPAGE="https://github.com/theskumar/python-dotenv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ >=dev-python/click-5[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/sh-1.09[${PYTHON_USEDEP}]
+ )"
+
+RESTRICT="test" # help fixing tests welcome, please get in touch
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest