summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 06:43:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 07:05:25 +0200
commitc65085f6e11638c8711e4ab34bf21267e49286d1 (patch)
tree12b687af0b5ad856f70ea3cdea272f034c62d13d
parentdev-python/selenium: Bump to 4.14.0 (diff)
downloadgentoo-c65085f6e11638c8711e4ab34bf21267e49286d1.tar.gz
gentoo-c65085f6e11638c8711e4ab34bf21267e49286d1.tar.bz2
gentoo-c65085f6e11638c8711e4ab34bf21267e49286d1.zip
dev-python/google-auth: Bump to 2.23.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.23.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index c7f0ebd8953d..1df08a322058 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1 +1,2 @@
DIST google-auth-2.23.2.tar.gz 232207 BLAKE2B 0de53f79bd908d7194253525de07075779ffc0ed33ef71e50004773ba85aee8e7392cd5cc87ad88b5f9ce90bc3eb19c0c094d0e76311d2cd93fb0bdb62ab2450 SHA512 d443b769e6ee7de6da14e31f8beb938aaf63edecafcbedda46b253bf0380dbd78a4508a0214f7a708a09c39d1d262cc93a290ec44e89fa05da7796828f33c1fd
+DIST google-auth-2.23.3.tar.gz 232472 BLAKE2B aab7c55e6037751f578c9b9ec83c2efac10bd0e9d755b56ff21cba68ce71baaff73f4947b00da54b02e41742f718b854d1c2efb88bf8ba8cb582c2425afcb29f SHA512 a561c1359e520e82de6faf3e0d60f8c072b96231ee2db54bea59ad9fa5caa505f91ab5b1008f7a3ebecdfcd70fbddbcfb5c19dfad8b0fe1424558284757aeb4b
diff --git a/dev-python/google-auth/google-auth-2.23.3.ebuild b/dev-python/google-auth/google-auth-2.23.3.ebuild
new file mode 100644
index 000000000000..3136de42f585
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.23.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}