summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-01 04:33:31 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-01 05:47:35 +0100
commitcb4daac897d68ee72ea8462bc99d1b2c9de4a6cd (patch)
treef049bbdd1e6c2858a630881b04aa82747b39a1df
parentapp-portage/emerge-delta-webrsync: add 3.7.9 (diff)
downloadgentoo-cb4daac897d68ee72ea8462bc99d1b2c9de4a6cd.tar.gz
gentoo-cb4daac897d68ee72ea8462bc99d1b2c9de4a6cd.tar.bz2
gentoo-cb4daac897d68ee72ea8462bc99d1b2c9de4a6cd.zip
dev-python/botocore: Bump to 1.34.32
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.32.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 648727e57e4f..dfbfd0f52d75 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.34.23.gh.tar.gz 12647072 BLAKE2B be20994714a1f31ac5272d5b7be8424
DIST botocore-1.34.29.gh.tar.gz 12665018 BLAKE2B 928c27ae62a5e2675dc5476af05a4390cbeaf9d5c64cae6a5af0d5348f703417f48431258fc7c4ad316908fd29f6bfeb5a7c76290ea9622172f3d787f40021c7 SHA512 5314900eecf2d31fe08bcb9efbc1a361467fe034129c85f5cb4a678275115292fc5a6a95fbbe3cc06aa0a1387e14dde0f9115a9aa25ba59dba62a02c3b8db43b
DIST botocore-1.34.30.gh.tar.gz 12666051 BLAKE2B b6a19b4145b17855a65ecfd89150613b460616413f55b112df54dd60fbd946d7bee1f33d615e859e9f56e49328ddb91cb9e1c9b350686a37eccb1892850dbdf0 SHA512 8ce09d2ffa190fb50fd2a9b98ad0bf36de886d5b9f2a0e833e425a0bbfedca7f98b8de50240eaa81d1b01b68bbc96f6fce706b0547a508140e615aa9c3927c26
DIST botocore-1.34.31.gh.tar.gz 12665042 BLAKE2B 2cf79fb1ea31921fd9c285b71d66fc645e3d22d599533eb30754c0b39337c871ac1d660bfe0786eccd9bc8d8e03c573cef00ab0363403e387df4fcffa9ad5fb3 SHA512 a740897de2c375b668b56af5ff6da3dd01b5420dcf4ae4a5f9805267c6b33f25364e16a1c2c199b18a95d6ed222be71ad9c6ba033cd0b45daf101f8b33c2b0b7
+DIST botocore-1.34.32.gh.tar.gz 12673734 BLAKE2B d9661e779e087c1628267b936f59991a39acae836e57e118b86bc51beeec8eb88898a66f461bbcd26479b12cc7acf22371a52dfde10198ddb2a48a6d5ac29c84 SHA512 1d9a119dfb91dc73e2011becbc06b38a87ac73386a9e05741a220303a5b886d45aeac425b34c68196606591d5e6d6e82f3883494fa9f28bea532d7bdd57a5620
diff --git a/dev-python/botocore/botocore-1.34.32.ebuild b/dev-python/botocore/botocore-1.34.32.ebuild
new file mode 100644
index 000000000000..c90392068414
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.32.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}