summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:56 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:55 +0100
commite2ebedd68251b7aeb618e8ec84477423a18c61a8 (patch)
tree7f123ab7e494c2f1caeb704574331352554f1f41
parentdev-haskell/netlink: add 1.1.1.0 (diff)
downloadgentoo-e2ebedd68251b7aeb618e8ec84477423a18c61a8.tar.gz
gentoo-e2ebedd68251b7aeb618e8ec84477423a18c61a8.tar.bz2
gentoo-e2ebedd68251b7aeb618e8ec84477423a18c61a8.zip
dev-haskell/network-info: add 0.2.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/network-info/Manifest1
-rw-r--r--dev-haskell/network-info/metadata.xml15
-rw-r--r--dev-haskell/network-info/network-info-0.2.1.ebuild22
3 files changed, 25 insertions, 13 deletions
diff --git a/dev-haskell/network-info/Manifest b/dev-haskell/network-info/Manifest
index 0dafbaa22964..3f1755712c23 100644
--- a/dev-haskell/network-info/Manifest
+++ b/dev-haskell/network-info/Manifest
@@ -1 +1,2 @@
DIST network-info-0.2.0.10.tar.gz 6278 BLAKE2B 52cec7dc2866ff0aad9f0180391c2e093d3147f7de1dd96baa7ec1f9d149792aca371d7f5bb3a32d254f2fd3a35f6a6b3fb479967ad7cb0a125944aca7eeaa88 SHA512 d578f64860fb3c04d11a444d9636bde57402b6728529e73c7741b056ef0d8f68cb0958118212f2d47826dc28ba9b2bfcc9aef8b5b2e9fc3da8eaadc796160895
+DIST network-info-0.2.1.tar.gz 6387 BLAKE2B 82ff522ddf8bb4b22fabda228148cc428cb847589727dfa18182d6516c1367a6549c07fdca4492c56a012e61b9e3fe168827bd31e837d8f6bea30f0dfef3e19d SHA512 a252bd5c34cbbde9dcdd9606b31ed9b9fa802edfc694795f8779fd8f4ffa9092df0ab25426e0a1dca836d74a9357c1b31acb2aa01a9e46e8ffd5959be7a5d619
diff --git a/dev-haskell/network-info/metadata.xml b/dev-haskell/network-info/metadata.xml
index 275cdcb01d77..870e8e27d82c 100644
--- a/dev-haskell/network-info/metadata.xml
+++ b/dev-haskell/network-info/metadata.xml
@@ -5,19 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library provides simple read-only access to the
- local computer's networking configuration. It is
- currently capable of getting a list of all the network
- interfaces and their respective IPv4, IPv6 and MAC
- addresses.
-
- network-info has been tested and is known to work on
- Ubuntu 10.10, FreeBSD 9.0, Mac OS X 10.6.4 and Windows
- XP/7. It probably works on other flavours of Linux,
- OS X, FreeBSD and Windows as well.
- </longdescription>
<upstream>
- <remote-id type="github">jystic/network-info</remote-id>
+ <remote-id type="hackage">network-info</remote-id>
+ <remote-id type="github">jacobstanley/network-info</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/network-info/network-info-0.2.1.ebuild b/dev-haskell/network-info/network-info-0.2.1.ebuild
new file mode 100644
index 000000000000..eb5ab6b19e2a
--- /dev/null
+++ b/dev-haskell/network-info/network-info-0.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Access the local computer's basic network configuration"
+HOMEPAGE="https://github.com/jacobstanley/network-info"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"