summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-03 08:17:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-03 08:20:42 -0400
commiteab63f3cad9afcdb07334876409c5b52d7e07ee5 (patch)
treeef862c59b545742e875a510a090395bceb4e8713
parentmedia-gfx/openpgl: add 0.6.0, use PV as subslot (diff)
downloadgentoo-eab63f3cad9afcdb07334876409c5b52d7e07ee5.tar.gz
gentoo-eab63f3cad9afcdb07334876409c5b52d7e07ee5.tar.bz2
gentoo-eab63f3cad9afcdb07334876409c5b52d7e07ee5.zip
dev-util/maturin: ensure -march is passed for s390x
Fails to build otherwise with: src/arch/zseries_linux.s: Assembler messages: src/arch/zseries_linux.s:49: Error: Unrecognized opcode: `lay' If really needed, there'd be the alternate option to sed /"s390x"/d from psm-*/build.rs, but passing -march is what maturin upstream does as well for their s390x builds. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-util/maturin/maturin-1.5.1-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/maturin/maturin-1.5.1-r1.ebuild b/dev-util/maturin/maturin-1.5.1-r1.ebuild
index 81f54669ac75..a692b2fa20a7 100644
--- a/dev-util/maturin/maturin-1.5.1-r1.ebuild
+++ b/dev-util/maturin/maturin-1.5.1-r1.ebuild
@@ -419,7 +419,7 @@ CRATES_TEST="
"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{10..12} )
-inherit cargo distutils-r1 shell-completion toolchain-funcs
+inherit cargo distutils-r1 flag-o-matic shell-completion toolchain-funcs
DESCRIPTION="Build and publish crates with pyo3, rust-cpython and cffi bindings"
HOMEPAGE="https://www.maturin.rs/"
@@ -488,6 +488,10 @@ src_prepare() {
src_configure() {
export OPENSSL_NO_VENDOR=1
+ # https://github.com/rust-lang/stacker/issues/79
+ use s390 && ! is-flagq '-march=*' &&
+ append-cflags $(test-flags-CC -march=z10)
+
local myfeatures=(
# like release.yml + native-tls for better platform support than rustls
full