summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-25 06:04:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-25 06:14:32 +0100
commitebfc5dfee0178e68e0aae5d7c00c1f9295c0e1fc (patch)
tree9fe4edc94c20ecd38358bfc075ba066e68a53ade
parentdev-python/pycodestyle: Bump to 2.10.0 (diff)
downloadgentoo-ebfc5dfee0178e68e0aae5d7c00c1f9295c0e1fc.tar.gz
gentoo-ebfc5dfee0178e68e0aae5d7c00c1f9295c0e1fc.tar.bz2
gentoo-ebfc5dfee0178e68e0aae5d7c00c1f9295c0e1fc.zip
dev-python/flake8: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-6.0.0.ebuild48
-rw-r--r--dev-python/flake8/metadata.xml2
3 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index d3381e630c3a..1b96b39d9102 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,2 +1,3 @@
DIST flake8-4.0.1.tar.gz 154905 BLAKE2B b93fea36236881da595ae924b056686e0cd35d2466c1858e3ee83262922df8bc38cf5cd40a910980d287d048572dc94eb8d7c8ee4b11ebd1b4a474dfca02490c SHA512 0bdbf0218ce893df1c3e61f51cd3f371a5c72bb49ef78fec39548b1684e49b024e91cf4e3dcea60ba1efc08727985ef485814c372461e062ff4f810da99a1796
DIST flake8-5.0.4.gh.tar.gz 146207 BLAKE2B c99ec0977948e98ca62106737509f7901b15871894f08c1dc82a4dfdf7567bc85eaca5918600fc42d0c82de612644df1b587e8a7c84fbe040d1402c3513e1855 SHA512 2e9f8bf2bbca1ab0b7cb0bc6aee53f7e12288194a80a8be915478061fd76adb8d270ee50383b45beb9d4dd1ee806f104e7bbf29f69b23a7cd88ee0902ff3e965
+DIST flake8-6.0.0.gh.tar.gz 139138 BLAKE2B 87590594a95f48a9e532ca545d4ae17a098cba81a7708066d63180b27e1cd0e0b648a2362d16b3818ef1b91cbe9ecf51810d45136fb42f188fc09083e9b31921 SHA512 27de4632332ee72bb5deedfcb7ea59e31a3e7fbfd6c165adf019b06cccaba51b776f4310219d8b27cf4894ed2597330fe9c0e381187353d4dc239f102eedd26a
diff --git a/dev-python/flake8/flake8-6.0.0.ebuild b/dev-python/flake8/flake8-6.0.0.ebuild
new file mode 100644
index 000000000000..442be0193ccd
--- /dev/null
+++ b/dev-python/flake8/flake8-6.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="
+ https://github.com/PyCQA/flake8/
+ https://pypi.org/project/flake8/
+"
+SRC_URI="
+ https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ <dev-python/pyflakes-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.10.0[${PYTHON_USEDEP}]
+"
+PDEPEND="
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails if additional flake8 plugins are installed
+ tests/integration/test_plugins.py::test_local_plugin_can_add_option
+)
diff --git a/dev-python/flake8/metadata.xml b/dev-python/flake8/metadata.xml
index 3a5a3fc849da..e9ec91a01fbd 100644
--- a/dev-python/flake8/metadata.xml
+++ b/dev-python/flake8/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">flake8</remote-id>
- <remote-id type="gitlab">pycqa/flake8</remote-id>
+ <remote-id type="github">PyCQA/flake8</remote-id>
</upstream>
</pkgmetadata>