summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-02 00:38:54 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-02 01:48:02 +0100
commita2c09cbf0b3d82b3aac2f5b4ad0d9012ffd971a5 (patch)
tree19ea1466d9af1cb6e9a82f597bec2db3bdf8bd2b /app-admin/ansible-lint
parentdev-perl/Date-Manip: add github upstream metadata (diff)
downloadgentoo-a2c09cbf0b3d82b3aac2f5b4ad0d9012ffd971a5.tar.gz
gentoo-a2c09cbf0b3d82b3aac2f5b4ad0d9012ffd971a5.tar.bz2
gentoo-a2c09cbf0b3d82b3aac2f5b4ad0d9012ffd971a5.zip
app-admin/ansible-lint: add 6.5.2, drop 6.5.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin/ansible-lint')
-rw-r--r--app-admin/ansible-lint/Manifest2
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.5.2.ebuild (renamed from app-admin/ansible-lint/ansible-lint-6.5.1.ebuild)2
-rw-r--r--app-admin/ansible-lint/files/ansible-lint-6.5.2_test-module-check.patch32
3 files changed, 34 insertions, 2 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index b0e3cc496c55..6df1669c4d41 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,2 +1,2 @@
DIST ansible-lint-6.4.0.gh.tar.gz 235346 BLAKE2B a2f55e6f4df739dccb011225f0a660978a9dfdbcc6e45cee2eef12467482c471d8700bb1bfad87e03eb1c4f21291307db5dc174e2440370ca11368f6ad6d195d SHA512 75e30a325a5c62f64066925b99e691886e299e029adc78fdceaa5eb23a74a46408793479e7c54c312d93e0a62d190b34f1e7614dec31a94822d39a231796e9df
-DIST ansible-lint-6.5.1.gh.tar.gz 244320 BLAKE2B aff13d6ce9346dbdba459722cfc071b1e671dc17f3fb44744a706097f29e2a6a9962514fc61e669b58517acf6e95feba88af1bf8c7a4fb668e1a8d1cc5d54746 SHA512 40890a3fc0caaa3fd1d38f32739615dd664db1e7ea534c0bc3138da7295cdc6923715ea12febefc8951be350aad5bf7ac76dd004e3c4aff386b78551bd6442a8
+DIST ansible-lint-6.5.2.gh.tar.gz 248425 BLAKE2B 02fe3f0cb410831ee7913c5f5ae434678ff183f9c60f0355988d69b516324513fd417439f9ceee4a38192c1e593d7bc00c8fd1aafdff6ba904cdb4ba56257657 SHA512 36a8d7b746bbb0c0f4d85a63180432b9165b1e59ff9da07f6b9477aa02d8998c5c682a317a04c4971a08f0691a10f420d9fd0e7d396d7d1b7f49979c7faf41f5
diff --git a/app-admin/ansible-lint/ansible-lint-6.5.1.ebuild b/app-admin/ansible-lint/ansible-lint-6.5.2.ebuild
index 117da9fdcf9e..ba4605d1720d 100644
--- a/app-admin/ansible-lint/ansible-lint-6.5.1.ebuild
+++ b/app-admin/ansible-lint/ansible-lint-6.5.2.ebuild
@@ -39,7 +39,7 @@ BDEPEND="
)"
PATCHES=(
- "${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
+ "${FILESDIR}"/${PN}-6.5.2_test-module-check.patch
)
# Skip problematic tests:
diff --git a/app-admin/ansible-lint/files/ansible-lint-6.5.2_test-module-check.patch b/app-admin/ansible-lint/files/ansible-lint-6.5.2_test-module-check.patch
new file mode 100644
index 000000000000..8e6cb512b633
--- /dev/null
+++ b/app-admin/ansible-lint/files/ansible-lint-6.5.2_test-module-check.patch
@@ -0,0 +1,32 @@
+Let the package managers handle dependencies, m'kay?
+
+--- a/conftest.py
++++ b/conftest.py
+@@ -7,27 +7,6 @@
+ import pytest
+ from ansible.module_utils.common.yaml import HAS_LIBYAML
+
+-# checking if user is running pytest without installing test dependencies:
+-missing = []
+-for module in ["ansible", "black", "flake8", "flaky", "mypy", "pylint"]:
+- if not importlib.util.find_spec(module):
+- missing.append(module)
+-if missing:
+- print(
+- f"FATAL: Missing modules: {', '.join(missing)} -- probably you missed installing test requirements with: pip install -e '.[test]'",
+- file=sys.stderr,
+- )
+- sys.exit(1)
+-
+-if not HAS_LIBYAML:
+- # While presence of libyaml is not required for runtime, we keep this error
+- # fatal here in order to be sure that we spot libyaml errors during testing.
+- print(
+- "FATAL: For testing, we require pyyaml to be installed with its native extension, missing it would make testing 3x slower and risk missing essential bugs.",
+- file=sys.stderr,
+- )
+- sys.exit(1)
+-
+
+ os.environ["NO_COLOR"] = "1"
+