summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-01 06:54:51 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-01 07:35:20 +0100
commit248352f5335a4f234d2bc8f29ad8aa8b035661f0 (patch)
treeea9f0c18dc33caf51416a824903eef6fd3ca5da6 /app-admin/awscli
parentdev-python/boto3: Bump to 1.35.53 (diff)
downloadgentoo-248352f5335a4f234d2bc8f29ad8aa8b035661f0.tar.gz
gentoo-248352f5335a4f234d2bc8f29ad8aa8b035661f0.tar.bz2
gentoo-248352f5335a4f234d2bc8f29ad8aa8b035661f0.zip
app-admin/awscli: Bump to 1.35.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.35.19.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 17a1989d270e..ac3ba9ede0a7 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,4 +3,5 @@ DIST aws-cli-1.35.15.gh.tar.gz 2810766 BLAKE2B 18a8464acede1801a533da89191c31309
DIST aws-cli-1.35.16.gh.tar.gz 2811312 BLAKE2B 0d3a243ecd9b1759fcecdb427693270136e6c00b6eeae592481eaf8a32bbf641659e096c7eb19fe550b05a1c2f4f79300191c3716c551bf0dd25a9bd41d6aeb6 SHA512 02caaac48ca08a97a3cd82a672fb2dcd4b66666a7b4de34c3420ee66c10c79aa10672603997f941a8c462c8094cc6c014aefbba5109f6cee75a546426ea00439
DIST aws-cli-1.35.17.gh.tar.gz 2814594 BLAKE2B 031bfa16aa8d1478a2c1b146a38182ee776869b3c512c51e4ae234f495c538cd941c7853ede3b28ef262637e56ffa32c95c130f4ece3d2495d2e993a5f4840fe SHA512 e0a873df808e2bfac61e2ed3b56c7da8d9f0b975839f9cad7dc4df5f2bb8c68d200694053b00da203fd5a4fb80cbd61742f0f2ec0cb544aa037e82b95466f99b
DIST aws-cli-1.35.18.gh.tar.gz 2816574 BLAKE2B 79f4fce1109cfc15248fa7c1aefc4c99127b881077c33204934a088ebf095745a1a7144a51c1e02acd3171ce207455fb47124508df30c2714b61109454e60157 SHA512 426bd2e2a8bb71c450fc90887096adebedc0ed885a9450d960b5d3ba7c335fcfbd18cb358c0b3f6b204568ac84804ec8ae36f4517e0dc6e78bd286c342d2de86
+DIST aws-cli-1.35.19.gh.tar.gz 2817293 BLAKE2B 4aeb6071c6c9974018ac62132d793473bb2a4fe4e4f9690e142c0ae45df575b52712dd7856d041296694508efa4508c279b23bd62c4ca5921449efe4091093c2 SHA512 76be1417ce7b99feeab75c1a4c3e81b62c82d50297fb3fbf631c92a6857084c0da6b1116a2bfd5a1b2e4d3aa1e8eaaff8987f4eaa491ef2fc59674bfd1efb6dd
DIST aws-cli-1.35.5.gh.tar.gz 2808789 BLAKE2B 545c76bd349485fbf2dc5565317678904c99443e2e6dc2e12fa9de122327d8aa0e8b9579cec37afe2e949a0c31c48e0977e52d701ffc212182c692769c35a948 SHA512 2a9c86f1a63b657d3c95f8a65020ea7837ded9f5147ce31a535f59b9d9c1c91c3354a82286c25252da7d5b7c48c1898f594be0cb9e1ba54c6768133543fcba50
diff --git a/app-admin/awscli/awscli-1.35.19.ebuild b/app-admin/awscli/awscli-1.35.19.ebuild
new file mode 100644
index 000000000000..0fc6192a8587
--- /dev/null
+++ b/app-admin/awscli/awscli-1.35.19.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.y.(z+34)
+BOTOCORE_PV="$(ver_cut 1).$(ver_cut 2).$(( $(ver_cut 3-) + 34 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ case ${EPYTHON} in
+ python3.13*)
+ EPYTEST_DESELECT+=(
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ ;;
+ esac
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}