summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-26 06:53:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-26 08:01:22 +0100
commit2622a78ed3afcea7d8281932c14cdf82d06dc8b9 (patch)
tree15094eac012638e99fe4cf259652d4ca703cbfaa /app-admin/awscli
parentdev-python/boto3: Bump to 1.35.69 (diff)
downloadgentoo-2622a78ed3afcea7d8281932c14cdf82d06dc8b9.tar.gz
gentoo-2622a78ed3afcea7d8281932c14cdf82d06dc8b9.tar.bz2
gentoo-2622a78ed3afcea7d8281932c14cdf82d06dc8b9.zip
app-admin/awscli: Bump to 1.36.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.36.10.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index d6ef94b32110..3711d35022ec 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST aws-cli-1.35.23.gh.tar.gz 2819656 BLAKE2B 6e9d20410344f075ce12bfc8c0a49941a846f02304de9a30516376d0b6666b8c0a9affb36dd94a463f48f17f478f5d27e0f7375a48c63eca1b3a28927211e6aa SHA512 9075af833da9abc9494a2dd01a987b874e2b4444d7d5d1f4f974da1b56940b88603e8ec115662c85c2beb7cb70a65c3bcdbbd5510a1973433f8030efc6a1c69a
+DIST aws-cli-1.36.10.gh.tar.gz 2836233 BLAKE2B 92c5d80b122e68e2b5fa647ed7c2d1a55e7c1d0f45005ab530e71ab70dbda6c90f37d0cb740e9f2e7c804ae62cfed6cd3b14ab3f80ec06ab35cb4ba823a72c78 SHA512 c881b0a202c9f388941832d1cf0c88158200ac1da7e6955d0284ea10abb71d0c816be6419a53e7c7264e177000ff37483ecf269bcc1c6920d2790be3b40afdfa
DIST aws-cli-1.36.4.gh.tar.gz 2825870 BLAKE2B 3a13a50077087633972c0eb908e0116e432f0036871f4d5a5e2429ea86dfc0c5d40a87e0950c02bc7622fb0e56b9a3ee9fc8ee9a6a1ed8ae17728bf479401d13 SHA512 735a228d52b525cfc4a9a403ad8364bfb9c558ba86daf6966743126eb21de6d0f49d76fd21d9c7a0fd29f229b4b71e0778d4b1ccd0b2e27b0c794f1e11cd6c83
DIST aws-cli-1.36.9.gh.tar.gz 2836018 BLAKE2B aada8a63f5bedd5aeeddd56fe18bb49ae1763ba5c737f72aa2f2e00b57fa4e1ab52ec266ca6883859ec633ec2b1658383426809870ba1372d86f9d8e0a055ac6 SHA512 ec47c26012027071732d60f9bd8b3322c1c75b2362dffe7affd8cd6d70732e6239bfbb6531759a247bcb2f29613a88b196d10f405302d25a05ada7968bd7574e
diff --git a/app-admin/awscli/awscli-1.36.10.ebuild b/app-admin/awscli/awscli-1.36.10.ebuild
new file mode 100644
index 000000000000..2960403cf7e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.10.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}