summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/elektra/elektra-0.8.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/elektra/elektra-0.8.6.ebuild')
-rw-r--r--app-admin/elektra/elektra-0.8.6.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/elektra/elektra-0.8.6.ebuild b/app-admin/elektra/elektra-0.8.6.ebuild
new file mode 100644
index 000000000000..b16fd291eabb
--- /dev/null
+++ b/app-admin/elektra/elektra-0.8.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-multilib eutils
+
+DESCRIPTION="universal and secure framework to store config parameters in a hierarchical key-value pair mechanism"
+HOMEPAGE="http://freedesktop.org/wiki/Software/Elektra"
+SRC_URI="ftp://ftp.markus-raab.org/${PN}/releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus doc examples iconv simpleini static-libs syslog tcl test +uname xml yajl"
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ iconv? ( >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}] )
+ uname? ( sys-apps/coreutils )
+ yajl? (
+ <dev-libs/yajl-2[${MULTILIB_USEDEP}]
+ >=dev-libs/yajl-1.0.11-r1[${MULTILIB_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )"
+
+DOCS="doc/AUTHORS doc/CHANGES doc/NEWS doc/README doc/todo/TODO"
+# tries to write to user's home directory (and doesn't respect HOME)
+RESTRICT="test"
+
+src_prepare() {
+
+ #move doc files to correct location
+ sed -e "s/elektra-api/${PF}/" \
+ -i cmake/ElektraCache.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local my_plugins="ccode;dump;error;fstab;glob;hexcode;hidden;hosts;network;ni;null;path;resolver;struct;success;template;timeofday;tracer;type;validation"
+
+ use dbus && my_plugins+=";dbus"
+ use doc && my_plugins+=";doc"
+ use iconv && my_plugins+=";iconv"
+ use simpleini && my_plugins+=";simpleini"
+ use syslog && my_plugins+=";syslog"
+ use tcl && my_plugins+=";tcl"
+ use uname && my_plugins+=";uname"
+ use xml && my_plugins+=";xmltool"
+ use yajl && my_plugins+=";yajl"
+
+ mycmakeargs=(
+ "-DPLUGINS=${my_plugins}"
+ "-DLATEX_COMPILER=OFF"
+ "-DTARGET_CMAKE_FOLDER=share/cmake/Modules"
+ $(multilib_is_native_abi && cmake-utils_use doc BUILD_DOCUMENTATION \
+ || echo -DBUILD_DOCUMENTATION=OFF)
+ $(multilib_is_native_abi && cmake-utils_use examples BUILD_EXAMPLES \
+ || echo -DBUILD_EXAMPLES=OFF)
+ $(cmake-utils_use static-libs BUILD_STATIC)
+ $(cmake-utils_use test BUILD_TESTING)
+ )
+
+ cmake-utils_src_configure
+}