summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-07-02 10:16:16 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-07-02 11:46:45 +0200
commita877d8061c001c557e78c6ee60254e6457b793eb (patch)
treea0a934e1934a7f254bf3f5ddee7c56a592773ae6 /app-admin/entr
parentdev-libs/libunibreak: bump to 6.1 (diff)
downloadgentoo-a877d8061c001c557e78c6ee60254e6457b793eb.tar.gz
gentoo-a877d8061c001c557e78c6ee60254e6457b793eb.tar.bz2
gentoo-a877d8061c001c557e78c6ee60254e6457b793eb.zip
app-admin/entr: add 5.6
Entr newly supports status filter [1,2], which can be enabled by -x or -xx parameters. Filtering is done by /usr/bin/awk spawned on background. Entr additionally passes the -S parameter to awk (in order to enable sandboxing) if the filter is enabled by -x. However, the -S parameter seems to be available only in gawk and tests cover the sandbox feature, therefore /usr/bin/awk must point to gawk, which is the reason why app-alternatives/awk[gawk] was added to BDEPEND. [1] https://github.com/eradman/entr/pull/141 [2] http://eradman.com/entrproject/status-filters.html Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-admin/entr')
-rw-r--r--app-admin/entr/Manifest1
-rw-r--r--app-admin/entr/entr-5.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/entr/Manifest b/app-admin/entr/Manifest
index 4d3e78c93ae2..db19310fb362 100644
--- a/app-admin/entr/Manifest
+++ b/app-admin/entr/Manifest
@@ -1 +1,2 @@
DIST entr-5.5.tar.gz 21225 BLAKE2B 8a160894220b63c510fe432a033ba7770e8811da4c5d642391a61a11ca1865293675bc3adbb505b70da9d01b258c27770bc07fad18de7a993e172b2b1214df9b SHA512 5150744142cf1639289c2d845cf8cd3cbc0ef57fce8285bc0e2908c430d8344659ff064810e175e69bd8a6f06144734b2efa4d733e0fba7fec83a1f48d053a0d
+DIST entr-5.6.tar.gz 23370 BLAKE2B 52b2e2d49d550c7ba82199cc70500598c50809136bc9bed881174ab59806802ac09cf7ff32f0476eeb66ee9fdb87bef72dbf28bfd4495f0301ee80809800dbfa SHA512 9c65449b6fd7e172fde23a6d4d776b6fdbcec210ef54234db0af056e481acd11f53f9b25432a278435943bd998be734fcd997b5debdcace58112ac99d103f653
diff --git a/app-admin/entr/entr-5.6.ebuild b/app-admin/entr/entr-5.6.ebuild
new file mode 100644
index 000000000000..e7f905243699
--- /dev/null
+++ b/app-admin/entr/entr-5.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="
+ https://eradman.com/entrproject/
+ https://github.com/eradman/entr
+"
+SRC_URI="https://eradman.com/entrproject/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-alternatives/awk[gawk]
+ app-editors/vim
+ app-misc/tmux
+ dev-vcs/git
+ sys-apps/file
+ )
+"
+
+src_configure() {
+ tc-export CC
+ export PREFIX="${EPREFIX}/usr"
+ export SHELL="${BROOT}/bin/bash"
+ export TMUX_TMPDIR="${T}"
+
+ edo ./configure
+}