summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2021-12-02 17:45:52 +1100
committerMichael Palimaka <kensington@gentoo.org>2021-12-02 17:45:52 +1100
commit4fed2d7d53d68fadee3e7a0912a692ddc809602f (patch)
treeebcbc9b60f1e25e4c72ac7797559a8015680c1e3 /app-admin/keepass
parentapp-admin/keepass: remove 2.46 (diff)
downloadgentoo-4fed2d7d53d68fadee3e7a0912a692ddc809602f.tar.gz
gentoo-4fed2d7d53d68fadee3e7a0912a692ddc809602f.tar.bz2
gentoo-4fed2d7d53d68fadee3e7a0912a692ddc809602f.zip
app-admin/keepass: remove 2.48.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/Manifest1
-rw-r--r--app-admin/keepass/keepass-2.48.1.ebuild116
2 files changed, 0 insertions, 117 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index f960bd37e211..92b3d0126d99 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,2 +1 @@
-DIST KeePass-2.48.1-Source.zip 5123663 BLAKE2B 919a109d114a8bc404a02f063a81013581f64e4e97fe0f024e3e0ca7a3da773a6a4af20447ab3641c3a9e82c861b8b7095793f917f0bbd69d8b443d2ce022a9f SHA512 1faa9f770fc7030f884a661d95f9d2d6d50627153fdf56331b7ad2cbaa4648e263697c999ca15e62a9946e0c6d4df45cf004ae21b715d99949967e25f4728d18
DIST KeePass-2.49-Source.zip 5135190 BLAKE2B bf5a9aab0065a97545bd1b81a74b5ab113e4c4802873445719ce2a571745b04c69ab5d8be9a67dc59a713947f0955cbcccc782b6628f722a0d564283b943eee6 SHA512 7a25de6acb2637bd8820fb70866ab4ced4ece4b3e64172f616c2fb59d2a4e7a2f340435db10731ed3d7e66db7761487925cf1c7941b0bac12e72c5fcd9e8b7d3
diff --git a/app-admin/keepass/keepass-2.48.1.ebuild b/app-admin/keepass/keepass-2.48.1.ebuild
deleted file mode 100644
index afa3624b3df1..000000000000
--- a/app-admin/keepass/keepass-2.48.1.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop optfeature wrapper xdg-utils
-
-MY_PN="KeePass"
-DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
-HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
-S="${WORKDIR}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="aot"
-
-BDEPEND="app-arch/unzip"
-DEPEND="dev-lang/mono"
-RDEPEND="
- ${DEPEND}
- dev-dotnet/libgdiplus[cairo]
-"
-
-PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
-
-# bug #687052
-# file generated by mono --aot where *FLAGS don't make sense
-QA_PREBUILT="usr/lib64/keepass/KeePass.exe.so"
-
-src_prepare() {
- # KeePass looks for some XSL files in the same folder as the executable,
- # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
- # This XSL file will not be upstreamed since the KeePass creator said that
- # including this patch would break the Portable USB version of KeePass
- # (which keeps/looks for xsl files in its own folder)
- default
-
- # Switch into build dir so the mono prepration script works correctly
- pushd Build || die
- source PrepMonoDev.sh || die
- popd || die
-}
-
-src_compile() {
- export MONO_REGISTRY_PATH=/dev/null # bug 659808
-
- # bug 704358
- export LANG=C LC_ALL=C
-
- # Build with Release target
- xbuild /target:KeePass /property:Configuration=Release || die
-
- # Run Ahead Of Time compiler on the binary
- if use aot; then
- cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
- mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
- fi
-}
-
-src_install() {
- # Wrapper script to launch mono
- make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
-
- # Some XSL files
- insinto "/usr/share/${PN}/XSL"
- doins Ext/XSL/*
-
- insinto "/usr/$(get_libdir)/${PN}"
- exeinto "/usr/$(get_libdir)/${PN}"
-
- doins Ext/KeePass.exe.config
-
- # Default configuration, simply says to use user-specific configuration
- doins Ext/KeePass.config.xml
-
- # The actual executable
- doexe Build/KeePass/Release/KeePass.exe
-
- # Copy the AOT compilation result
- if use aot; then
- doexe Build/KeePass/Release/KeePass.exe.so
- fi
-
- # Prepare the icons
- newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
- newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
-
- # Create a desktop entry and associate it with the KeePass mime type
- make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
-
- # MIME descriptor for .kdbx files
- insinto /usr/share/mime/packages
- doins "${FILESDIR}/${PN}.xml"
-
- # sed, because patching this really sucks
- sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-
- optfeature "enables autotype/autofill" x11-misc/xdotool
-
- elog "Some systems may experience issues with copy and paste operations."
- elog "If you encounter this, please install x11-misc/xsel."
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}