summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-05-19 09:36:42 +0100
committerMarek Szuba <marecki@gentoo.org>2023-05-19 09:37:39 +0100
commit02e2e4a6fa33e33d73a43c1b257350ee00aa004a (patch)
tree499d8df7aeca5bd70efeeed2356614e8d5365615 /app-admin/keepassxc
parentsys-apps/fwupd: add 1.8.15, drop 1.8.11-r1 (diff)
downloadgentoo-02e2e4a6fa33e33d73a43c1b257350ee00aa004a.tar.gz
gentoo-02e2e4a6fa33e33d73a43c1b257350ee00aa004a.tar.bz2
gentoo-02e2e4a6fa33e33d73a43c1b257350ee00aa004a.zip
app-admin/keepassxc: add 2.7.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/Manifest1
-rw-r--r--app-admin/keepassxc/keepassxc-2.7.5.ebuild100
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild5
3 files changed, 103 insertions, 3 deletions
diff --git a/app-admin/keepassxc/Manifest b/app-admin/keepassxc/Manifest
index 67aa48a88ca0..ab65dd45f920 100644
--- a/app-admin/keepassxc/Manifest
+++ b/app-admin/keepassxc/Manifest
@@ -1 +1,2 @@
DIST keepassxc-2.7.4-src.tar.xz 8957372 BLAKE2B 5b8ea105c35956f85779187df624f373f9e6937e1edc454b2a5cbc851ddd2ef0dd556ec74242e3a67c314c1e4b0750987a498d245c3463a5e92254ad0c394ab4 SHA512 76b6ba0891d9ba92a5794ba6f25dc8a28f7c1c0f010c31dd49d52ac4c5f186d9c4b51e6f054102b6dfe2d8e766607455829c1994c7ea238efc8f172bbe29b8eb
+DIST keepassxc-2.7.5-src.tar.xz 8706996 BLAKE2B 6df7ec9e560b469b8e3ae9026464e6c2064ffd262b118842a3cd5fbf72758aa0e5614cb2581392b6ab35b3d202acbdad24e1679ca162468f78e88dd94af2422f SHA512 904fe319cb18a06e86162a0a4c4fbcac05b9e6936b69c5362b7fe2b89cd268061cadd6854f7dde80d3e8cfa2b9e22c27974277f3db1f6c32a2720e01a4c4aa1b
diff --git a/app-admin/keepassxc/keepassxc-2.7.5.ebuild b/app-admin/keepassxc/keepassxc-2.7.5.ebuild
new file mode 100644
index 000000000000..d1389c67cc81
--- /dev/null
+++ b/app-admin/keepassxc/keepassxc-2.7.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
+HOMEPAGE="https://keepassxc.org/
+ https://github.com/keepassxreboot/keepassxc/"
+
+if [[ "${PV}" != *9999 ]] ; then
+ if [[ "${PV}" == *_beta* ]] ; then
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+ fi
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
+ [[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
+fi
+
+LICENSE="LGPL-2.1 GPL-2 GPL-3"
+SLOT="0"
+IUSE="X autotype browser doc keeshare +network test yubikey"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="autotype? ( X )"
+
+RDEPEND="
+ app-crypt/argon2:=
+ dev-libs/botan:2=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ media-gfx/qrencode:=
+ sys-libs/readline:0=
+ sys-libs/zlib:=
+ X? ( dev-qt/qtx11extras:5 )
+ autotype? (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ keeshare? ( sys-libs/zlib:=[minizip] )
+ yubikey? (
+ dev-libs/libusb:1
+ sys-apps/pcsc-lite
+ )
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ doc? ( dev-ruby/asciidoctor )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.7.4-tests.patch )
+
+src_prepare() {
+ if [[ "${PV}" != *_beta* ]] && [[ "${PV}" != *9999 ]] && [[ ! -f .version ]] ; then
+ printf '%s' "${PV}" > .version || die
+ fi
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # https://github.com/keepassxreboot/keepassxc/issues/5801
+ filter-flags -flto*
+
+ local mycmakeargs=(
+ # Gentoo users enable ccache via e.g. FEATURES=ccache or
+ # other means. We don't want the build system to enable it for us.
+ -DWITH_CCACHE=OFF
+ -DWITH_GUI_TESTS=OFF
+ -DWITH_TESTS="$(usex test)"
+ -DWITH_XC_AUTOTYPE="$(usex autotype)"
+ -DWITH_XC_DOCS="$(usex doc)"
+ -DWITH_XC_BROWSER="$(usex browser)"
+ -DWITH_XC_FDOSECRETS=ON
+ -DWITH_XC_KEESHARE="$(usex keeshare)"
+ -DWITH_XC_NETWORKING="$(usex network)"
+ -DWITH_XC_SSHAGENT=ON
+ -DWITH_XC_UPDATECHECK=OFF
+ -DWITH_XC_YUBIKEY="$(usex yubikey)"
+ -DWITH_XC_X11="$(usex X)"
+ )
+ if [[ "${PV}" == *_beta* ]] ; then
+ mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
+ fi
+ cmake_src_configure
+}
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 2254b764e96e..6a9c59967077 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -11,11 +11,10 @@ HOMEPAGE="https://keepassxc.org/
if [[ "${PV}" != *9999 ]] ; then
if [[ "${PV}" == *_beta* ]] ; then
- SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
else
- #SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
+ SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
else