summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-06-02 11:01:43 -0400
committerCraig Andrews <candrews@gentoo.org>2024-06-02 11:03:21 -0400
commite2c99eaf625e0013ce4523cdc35a32fdc51aaa49 (patch)
treea85e7a949508c54bb009a26f359adfeaa3c91894 /app-admin/needrestart
parentnet-p2p/nicotine+: Stabilize 3.2.9-r1 ppc, #933404 (diff)
downloadgentoo-e2c99eaf625e0013ce4523cdc35a32fdc51aaa49.tar.gz
gentoo-e2c99eaf625e0013ce4523cdc35a32fdc51aaa49.tar.bz2
gentoo-e2c99eaf625e0013ce4523cdc35a32fdc51aaa49.zip
app-admin/needrestart: make sys-apps/init-system-helpers optional
Closes: https://bugs.gentoo.org/933375 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-admin/needrestart')
-rw-r--r--app-admin/needrestart/needrestart-3.6-r1.ebuild42
-rw-r--r--app-admin/needrestart/needrestart-9999.ebuild6
2 files changed, 45 insertions, 3 deletions
diff --git a/app-admin/needrestart/needrestart-3.6-r1.ebuild b/app-admin/needrestart/needrestart-3.6-r1.ebuild
new file mode 100644
index 000000000000..d530994f324f
--- /dev/null
+++ b/app-admin/needrestart/needrestart-3.6-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/liske/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/liske/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Restart daemons after library updates"
+HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
+IUSE="systemd"
+SLOT="0"
+LICENSE="GPL-2+"
+
+RDEPEND="
+ >=sys-apps/sed-4.2.2
+ dev-lang/perl:=
+ dev-perl/libintl-perl
+ dev-perl/Module-Find
+ dev-perl/Module-ScanDeps
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/TermReadKey
+ !systemd? ( sys-apps/init-system-helpers )
+ amd64? ( sys-apps/iucode_tool )
+ x86? ( sys-apps/iucode_tool )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_install() {
+ default
+ doman man/*.1
+ dodoc -r ex
+}
diff --git a/app-admin/needrestart/needrestart-9999.ebuild b/app-admin/needrestart/needrestart-9999.ebuild
index c773506fddc2..d530994f324f 100644
--- a/app-admin/needrestart/needrestart-9999.ebuild
+++ b/app-admin/needrestart/needrestart-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -14,7 +14,7 @@ fi
DESCRIPTION="Restart daemons after library updates"
HOMEPAGE="https://fiasko-nw.net/~thomas/tag/needrestart.html https://github.com/liske/needrestart"
-
+IUSE="systemd"
SLOT="0"
LICENSE="GPL-2+"
@@ -27,7 +27,7 @@ RDEPEND="
dev-perl/Proc-ProcessTable
dev-perl/Sort-Naturally
dev-perl/TermReadKey
- sys-apps/init-system-helpers
+ !systemd? ( sys-apps/init-system-helpers )
amd64? ( sys-apps/iucode_tool )
x86? ( sys-apps/iucode_tool )
"