summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-26 13:35:49 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-26 13:42:37 +0100
commit1b6e0d9fc9ac14f7f6e99543f2778ba22d854f98 (patch)
tree20720cadbefd39d7334b23a03052ba7c9c9d1d9d /app-admin/radmind/radmind-1.15.1.ebuild
parentnet-irc/epic5: Bump to 2.0.1 (diff)
downloadgentoo-1b6e0d9fc9ac14f7f6e99543f2778ba22d854f98.tar.gz
gentoo-1b6e0d9fc9ac14f7f6e99543f2778ba22d854f98.tar.bz2
gentoo-1b6e0d9fc9ac14f7f6e99543f2778ba22d854f98.zip
app-admin/radmind: Bump to 1.15.1
Closes: https://bugs.gentoo.org/675614 Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-admin/radmind/radmind-1.15.1.ebuild')
-rw-r--r--app-admin/radmind/radmind-1.15.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/radmind/radmind-1.15.1.ebuild b/app-admin/radmind/radmind-1.15.1.ebuild
new file mode 100644
index 000000000000..6f595b238a99
--- /dev/null
+++ b/app-admin/radmind/radmind-1.15.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command-line tools and server to remotely administer multiple Unix filesystems"
+HOMEPAGE="http://rsug.itd.umich.edu/software/radmind/ https://github.com/voretaq7/radmind"
+SRC_URI="https://github.com/voretaq7/radmind/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}
+ !dev-util/repo
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.0-gentoo.patch
+ "${FILESDIR}"/${PN}-1.14.1-glibc225.patch
+)
+
+src_install() {
+ default
+ keepdir /var/radmind/{cert,client,postapply,preapply}
+}