summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/stow
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/stow')
-rw-r--r--app-admin/stow/Manifest1
-rw-r--r--app-admin/stow/files/99stow3
-rw-r--r--app-admin/stow/files/stow-2.2.0-avoid-precedence-warning.patch13
-rw-r--r--app-admin/stow/metadata.xml13
-rw-r--r--app-admin/stow/stow-2.2.0-r2.ebuild46
5 files changed, 76 insertions, 0 deletions
diff --git a/app-admin/stow/Manifest b/app-admin/stow/Manifest
new file mode 100644
index 000000000000..1ae23061477f
--- /dev/null
+++ b/app-admin/stow/Manifest
@@ -0,0 +1 @@
+DIST stow-2.2.0.tar.gz 479109 SHA256 8b89d79939cf9ae87d2f223bb36a3b2d0c66775b62aeb9953c6d33dab40d3c2b SHA512 43de6eddd6d8323682c6f5d4de00131009b7685a937c2a88ea1596cf9e12ced073983af571255d90c6e205c60dd976668f067909c92a9bce8ba0dfd984b253be WHIRLPOOL 0148d5b8c152a2058c5856c3b3503615860228fc12c19bd5f2a959b1cd756e51df65fb26593f84d27b317c43b3d26eabe1cd3d365282fa8a6b0e04979afcf12c
diff --git a/app-admin/stow/files/99stow b/app-admin/stow/files/99stow
new file mode 100644
index 000000000000..07625f392537
--- /dev/null
+++ b/app-admin/stow/files/99stow
@@ -0,0 +1,3 @@
+LDPATH=/var/lib/lib
+PATH=/var/lib/bin
+MANPATH=/var/lib/share/man
diff --git a/app-admin/stow/files/stow-2.2.0-avoid-precedence-warning.patch b/app-admin/stow/files/stow-2.2.0-avoid-precedence-warning.patch
new file mode 100644
index 000000000000..75838e3a7c62
--- /dev/null
+++ b/app-admin/stow/files/stow-2.2.0-avoid-precedence-warning.patch
@@ -0,0 +1,13 @@
+--- lib/Stow.pm.in
++++ lib/Stow.pm.in
+@@ -1734,8 +1734,8 @@ sub read_a_link {
+ }
+ elsif (-l $path) {
+ debug(4, " read_a_link($path): real link");
+- return readlink $path
+- or error("Could not read link: $path");
++ my $target = readlink $path or error("Could not read link: $path ($!)");
++ return $target;
+ }
+ internal_error("read_a_link() passed a non link path: $path\n");
+ }
diff --git a/app-admin/stow/metadata.xml b/app-admin/stow/metadata.xml
new file mode 100644
index 000000000000..fe6e121f44e2
--- /dev/null
+++ b/app-admin/stow/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>ewfalor@gmail.com</email>
+ <name>Erik Falor</name>
+ </maintainer>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/stow/stow-2.2.0-r2.ebuild b/app-admin/stow/stow-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..87d6617ffa97
--- /dev/null
+++ b/app-admin/stow/stow-2.2.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Manage installation of software in /var/lib/"
+HOMEPAGE="http://www.gnu.org/software/stow/"
+SRC_URI="mirror://gnu/stow/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+DEPEND="dev-lang/perl
+ test? (
+ virtual/perl-Test-Harness
+ dev-perl/Test-Output
+ )"
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-avoid-precedence-warning.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ # create new STOWDIR
+ dodir /var/lib/stow
+
+ # install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}"/99stow || die "doenvd failed"
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/stow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264 for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/stow/bin."
+}