summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-11-10 19:05:49 +0100
committerSebastian Pipping <sping@gentoo.org>2023-11-10 19:08:07 +0100
commit47315ecb859ff85be2dcfec818108517bb285208 (patch)
tree97e7dd0c100c1f1b9bb0f3fc1dfb3de8bb4edbe1 /app-admin/ttyplot
parentmedia-fonts/noto: Stabilize 20230930 sparc, #917129 (diff)
downloadgentoo-47315ecb859ff85be2dcfec818108517bb285208.tar.gz
gentoo-47315ecb859ff85be2dcfec818108517bb285208.tar.bz2
gentoo-47315ecb859ff85be2dcfec818108517bb285208.zip
app-admin/ttyplot: 1.5.1 (new package)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-admin/ttyplot')
-rw-r--r--app-admin/ttyplot/Manifest1
-rw-r--r--app-admin/ttyplot/metadata.xml11
-rw-r--r--app-admin/ttyplot/ttyplot-1.5.1.ebuild24
3 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/ttyplot/Manifest b/app-admin/ttyplot/Manifest
new file mode 100644
index 000000000000..ccf1665f40c1
--- /dev/null
+++ b/app-admin/ttyplot/Manifest
@@ -0,0 +1 @@
+DIST 1.5.1.gh.tar.gz 43629 BLAKE2B 98c46c27587a6ed98f7ed146b402dcbb6f5835f2f34780ccd706dc56b674dec3792dfb8bf84c8d260c040952ef0431341df09c16d032f32d4621c5f3971857d7 SHA512 3eb255375366bc3a773364388dc709f4f5b9961e1c99404dfd192503b20a8eb064f5089811b8c894a8214f84d24e14d040adb0b34712915311eb28972586bf0b
diff --git a/app-admin/ttyplot/metadata.xml b/app-admin/ttyplot/metadata.xml
new file mode 100644
index 000000000000..ae2c63465dde
--- /dev/null
+++ b/app-admin/ttyplot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tenox7/ttyplot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/ttyplot/ttyplot-1.5.1.ebuild b/app-admin/ttyplot/ttyplot-1.5.1.ebuild
new file mode 100644
index 000000000000..17db22ea1f97
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${PV}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}