summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-02 11:31:43 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-02 13:22:30 +0200
commit07cc6edafa88f009bff419650429ec21df78ecc1 (patch)
treeee80bbfb1dcf60bbba1b79842cddc625eef932de /app-admin
parentdev-python/boto3: Bump to 1.35.31 (diff)
downloadgentoo-07cc6edafa88f009bff419650429ec21df78ecc1.tar.gz
gentoo-07cc6edafa88f009bff419650429ec21df78ecc1.tar.bz2
gentoo-07cc6edafa88f009bff419650429ec21df78ecc1.zip
app-admin/awscli: Bump to 1.34.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.34.31.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 621456ee7834..9fc2c0039ad0 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,3 +1,4 @@
DIST aws-cli-1.34.19.gh.tar.gz 2795240 BLAKE2B ede95bb83dffdef1cbc6896f35e6926e3f7fe1cf27a091c019a4edadc57c24a88d06900fc6542fcf78c21f57de6651759a8ebd44952b21864313269c1cbfb289 SHA512 a82299d7f2d2fbb4600c91739b38e22e83eb95ffae0e70ef62e95ba039de6a47ba1d4e2423190a5e8ee59bf768a85181153c60329b9bbfc1a3e794d07d50dc75
DIST aws-cli-1.34.24.gh.tar.gz 2798088 BLAKE2B 24d5b74da8e6e1b97cd8c3558d28581acbb48250caa0a33ad9635068a358b6a0e450446d1486783e4208bb067f00616cb4c708c1674bb43ac3f9b7630d4116d2 SHA512 cb1d9fcf322e68a69f732a95c39701d937e83ea91a73b93dc565a7bb575c0f79b6a3cf0f47253321b3e54d9c5824b054798f53f5f82f9a29f94758c3a19aa4f9
DIST aws-cli-1.34.29.gh.tar.gz 2800945 BLAKE2B 93d9b41dfb2d80546f6cd601ff339053b6fef760bf9359d56b2d3835c1a8cca21146b492100db611c1bbe8601ad143dde0490b86d63eba7707141a5ca0c6aecb SHA512 9174fbc0e552d708916080b8b3d5b6b1e871332ac2a8b65b27091745b4537120d97c99ced878c861960f81b8368cb564a1fe573c9dc528c343b2100fc0ea6b08
+DIST aws-cli-1.34.31.gh.tar.gz 2802205 BLAKE2B dbdf6124a47756dc1ce93dafd3a3ceedfa8569a96e467cd2d5f44f42b642e5701e2bfb690000e01737ef126f554325998dd51b42007947848ce69512a0aafeb7 SHA512 4db1e625b1a64906b8c01371f594b32208e82c1d3eed59fb54aedddd147c64501b5d6f5d07c3483675a4bf81a0260be359b249f830fc084d7f04557760cd995c
diff --git a/app-admin/awscli/awscli-1.34.31.ebuild b/app-admin/awscli/awscli-1.34.31.ebuild
new file mode 100644
index 000000000000..599b9bd389b9
--- /dev/null
+++ b/app-admin/awscli/awscli-1.34.31.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}