summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-15 12:29:03 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-15 12:56:42 +0100
commit6d6638f1374916f92d2ceaee08d05eea47abea51 (patch)
tree3a99a267a9536bdc13912e827deaca3c78f03e77 /app-admin
parentgames-strategy/widelands: sync live (diff)
downloadgentoo-6d6638f1374916f92d2ceaee08d05eea47abea51.tar.gz
gentoo-6d6638f1374916f92d2ceaee08d05eea47abea51.tar.bz2
gentoo-6d6638f1374916f92d2ceaee08d05eea47abea51.zip
app-admin/ansible: drop 2.11.1
This is in fact ansible-base (or to be precise ansible-core, upstream renamed it in 2.11). Upstream continues to publish 'ansible' releases, and they do include collections previously constituting part of Ansible itself [2, 3]. Conversely, "upgrading" from ansible to ansible-base/ansible-core removes all core modules/plug-ins, breaking all playbooks which do not explicitly fetch *all* the required modules through other means. As explained on gentoo-dev back when 2.10.0 came out and exactly the same thing happened. [1] app-admin/ansible-base [2] https://github.com/ansible-collections/overview/blob/main/README.rst#q-once-the-next-version-of-ansible-is-released-will-my-playbooks-still-work [3] https://pypi.org/project/ansible/ Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.11.1.ebuild63
-rw-r--r--app-admin/ansible/ansible-9999.ebuild3
3 files changed, 1 insertions, 66 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 393d4983539b..67022ca9598a 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,2 +1 @@
DIST ansible-2.10.7.tar.gz 29862966 BLAKE2B fa86deaac034adc8e02f91cbf4b63ca718d50376cab19e156c85f8372c1787275e2ce24840fc3cbad2b9191146c785feafcf024a0c14052ee39a839390cc1319 SHA512 7a6522bcc57c178c9c6e87e313f6f175d5c74ac0d1b9dd0cad5506c7fa0efb16d4a627dc2d9c73f988177544bd9ccfdbec162d0feacc757edeb20280d7414191
-DIST ansible-core-2.11.1.tar.gz 6148111 BLAKE2B 46b1553542adbebfb0b0756be99a81d20cce2978a59766c65632b40413a851ad3c9de12df67959c0557584c5209ecd4f3c94381ae0a1e6987bd3cfb237de5a85 SHA512 1362754dde0a88ca8f6323d87cc6f4bf5f93b189b8d45fcb435d3fb289c359da128e7688a92107ade2c54828d4c4deb3ded9e01e18d19c503306924aa189a381
diff --git a/app-admin/ansible/ansible-2.11.1.ebuild b/app-admin/ansible/ansible-2.11.1.ebuild
deleted file mode 100644
index 157aa3810680..000000000000
--- a/app-admin/ansible/ansible-2.11.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}-core/${PN}-core-${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
-fi
-S="${WORKDIR}/${PN}-core-${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/resolvelib[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
- !app-admin/ansible-base
-"
-DEPEND="
- !app-admin/ansible-base
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index 1925abcf423d..c50250cd5308 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -16,10 +16,9 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/ansible/ansible.git"
EGIT_BRANCH="devel"
else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}-core/${PN}-core-${PV}.tar.gz"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
fi
-S="${WORKDIR}/${PN}-core-${PV}"
LICENSE="GPL-3"
SLOT="0"